Urgent help needed yellow tang help

wookie

Shrimp
Joined
18 Apr 2014
Posts
329
Reaction score
9
Location
pinetown kzn
Hi guys my yellow tang has all.of a sudden developed these red blotches. He is eating well and eats everything. How do I treat it Google says bacterial infection. Has any one else had this on their tang.

20160105_172647.jpg


20160105_172610.jpg
 

wookie

Shrimp
Joined
18 Apr 2014
Posts
329
Reaction score
9
Location
pinetown kzn
I just did a water change on Sunday. My nitrates 0.2
P03 0.01
 

flappy

Cardinal
Joined
18 Jul 2007
Posts
1,290
Reaction score
60
Location
Cape Town
Your No3 seems very low at 0.2ppm..how do you measure that?...do you mean 20ppm?
If your water parameters are in line I would add Seachem Kanaplex and Seachem Focus to the food...(Its a good antibiotic that targets gram negative and some gram positive bacteria)
 

wookie

Shrimp
Joined
18 Apr 2014
Posts
329
Reaction score
9
Location
pinetown kzn
No it is 0.2 not 20 my nutrients are low. Water tested at my lfs. Thanks will look into that seachem product
 
Last edited:

butcherman

Moderator
Joined
7 Sep 2009
Posts
11,783
Reaction score
320
Location
Kempton Park
Are running carbon in a reactor perhaps?

If so its the carbon being fluidized that's giving the yellow tang early signs of head and lateral line erosion, I had the exact same on my yellow tang.

I suspended the use of carbon and he recovered
 

wookie

Shrimp
Joined
18 Apr 2014
Posts
329
Reaction score
9
Location
pinetown kzn
Hi butcherman no not running carbon but running bio pellets in a reactor for No3 and po4 would this be the cause ?
 

Christo

Cardinal
Joined
4 Jun 2008
Posts
1,437
Reaction score
317
Location
Vaalpark, Vaaltriangle
Like @butcherman said, Common occurrence when Running Pellets. It Normaly starts if you just started using Pellets or you Toped up your Pellets! If It was me..... Just leave him be! Will go away by itself. No nead to stress him. Looks Nice and healthy.
 

wookie

Shrimp
Joined
18 Apr 2014
Posts
329
Reaction score
9
Location
pinetown kzn
Hi running about 80 mills of these pellets having added anymore only that amount from the start. It does get less on him and a couple of days later is back again like in the pic. Thanks for the help guys .

20160106_183409.jpg
 

wookie

Shrimp
Joined
18 Apr 2014
Posts
329
Reaction score
9
Location
pinetown kzn
No I don't but no stray voltage all my pumps are dc pumps my last tank shocked to badly so changed everything to dc
 

Similar threads


Top