warranty on a reef octo pump

Discussion in 'Protein Skimmers, Mechanical Filtration' started by Furbz, 17 Sep 2009.

  1. Furbz

    Furbz

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    hi guys.

    got home to a house smelling of burnt plastic!!

    my reef octopus pump for my TS1 skimmer had failed and was bubbling nasty gases through my tank water!

    no idea why it failed. was fully submerged and was working fine 3 hours ago.
    i took it apart and check the impeller. clean as a whistle and i can rotate it very easily.

    now the big questions!

    will the gases that this failed pump affect my water at all??
    should i be worried???
    i think i was lucky that i walked in when i did cos i think i just caught it as it happened.

    the second is that i am now way pissed off at reef octopus.
    i maintained and cleaned that pump properly and out of the blue it fails like this??
    is there any warranty or guarantee i can fall back on?
    my guess is that it is around a year old. will have to check up on the real age
     
  2. AdS Guest




    to hide all adverts.
  3. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Furbz. I suggest running some carbon and doing a water change just in case....
    In terms of the warranty, they usually come with a one year warranty.
     
  4. IMarine

    IMarine

    Joined:
    20 Oct 2007
    Posts:
    1,512
    Likes Received:
    16
    Location:
    walmer estate capetown
    mek excellent advice and furbz i had seen 2 pumps on there range give problems,but was sorted out by the lfs,the problem with the pumps is there is no filter sponge to protect the impellor from getting any sand or tiny stones in the pump,in most cases a stone gets sucked up by the pump and causes problems
     
    Last edited: 17 Sep 2009
  5. sweetnsour

    sweetnsour

    Joined:
    15 Jul 2009
    Posts:
    1,728
    Likes Received:
    8
    Location:
    JHB East Rand
    Furbs what does this gasses look like? I got home tonight and found my cube running with freshwater fouled!!!! The water is cloudy and was cristal clear yesterday?
    I hope my pump aint stuffed
     
  6. IMarine

    IMarine

    Joined:
    20 Oct 2007
    Posts:
    1,512
    Likes Received:
    16
    Location:
    walmer estate capetown
    another pump **** whats hapening with reefoct pumps
     
  7. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    did a 160L water change and the water still smells noxious. 5 anthias are dead. **** **** ****!!
    clean out my skimmer cup and it smells like very concentrated with the smell.
    thank god i have 2 skimmers in this system!
    skimming wet and will be doing another 130L water change 2mrw evening when i have the water.
     
  8. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    got brand new carbon in the tank. man i hope this works. my brain looks very upset..
     
  9. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Furbz. If you can do another water change right now, do it.
     
  10. IMarine

    IMarine

    Joined:
    20 Oct 2007
    Posts:
    1,512
    Likes Received:
    16
    Location:
    walmer estate capetown
    add stabality and tripple dose
     
  11. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    the chances of that in my case are a million to 1.

    skimmer is (was) in 3rd compartment. and no dsb has been setup.
    araganite would have to travel from display thru buffer boards over large slow flow compartment for DSB and then get into skimmer.
    not impossible but very very unlikely..
     
  12. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton

    did the biggest i could! thank god i had my newly mixed salt water from my nano. keep in for these ocassions! also had a barrel of water and did a quick mix.

    will do the same procedure 2mrw...
     
  13. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton

    did the water change and added around 500ml of stability..
     
  14. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    ok, did a bit of looking back in time...
    this pump is less than a year old?? not sure this should have happened??
     
  15. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    There seems to be a common problem with a certain batch of OTP1000 pumps. On my ReefOcto Carx, I blew 3 pumps and eventually turned to Haliea which gave me no hassles.
     
  16. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    i am just way pissed off it has killed 5 of my fish!! that a lot of cash (and life!) down the drain that should not have happened if the pumps were made properly...

    will contact the LFS and see what he can do.
    this pump is just under a year old..
    will also contact reefocto and see what they have to say.

    i am fuming!!!
     
  17. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    hey sweetnsour. you'd know if it was a pump... it smells like burning rubber. highly unkind to the nostrils. will make you feel like vomiting, and gives a nast headache i might add...

    as for the bubbles the pump was giving off.. they were solid white and coming from where the wire disappears into the pump.

    i ran a tank once with just tape water in it to test for leaks. left it running a few days and the water slowly turned a little milky... i think that is normal. not sure what causes it, but its def not your pump
     
  18. IMarine

    IMarine

    Joined:
    20 Oct 2007
    Posts:
    1,512
    Likes Received:
    16
    Location:
    walmer estate capetown
    airstone

    Hi add a air stone aswell and run the whole night
     
  19. Furbz

    Furbz Thread Starter

    Joined:
    12 May 2008
    Posts:
    2,202
    Likes Received:
    16
    Location:
    Sandton
    ok guys. i will post 2mrw morning and let you guys know how it goes.
    hold thumbs no other livestock dies...
     
  20. leslie hempel

    leslie hempel Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    14,530
    Likes Received:
    280
    Location:
    Gonubie East London
    can we clarify exactly what pump this is as i know the OTP pumps and the Hailea to be the same thing..
     
  21. lIghty

    lIghty

    Joined:
    3 Nov 2007
    Posts:
    5,053
    Likes Received:
    52
    Location:
    Westville, Durban
    The gasses have probably released Cu into the water to. I've used "water conditioner" (Think it was for Fresh water - but removes heavy metals) and worked like a charm, just that the other skimmer will go mad!
     
Recent Posts

Loading...
Similar Threads - warranty reef octo Forum Date
Buying Authentic Products and warranty validity Reef Aquatics 16 Sep 2014
MP40 Warranty? ► Sponsor Request Forum 1 Apr 2013
Warranty not honoured General Discussions and Advice 16 Mar 2009
[wtd] Seneye reef Wanted Wednesday at 09:57
[wtd] reefoctopus xps 5000 skimmer Wanted Tuesday at 09:03
Reef Octopus int5000 General Discussions and Advice 24 Nov 2016
Jaun's 240 mixed reef Medium Tanks 22 Nov 2016