Turbos and nerite's

Discussion in 'General Discussions and Advice' started by lanzo, 10 Sep 2007.

  1. lanzo

    lanzo Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    Hey Hey!!!:wave2:

    Do anyone know were can i buy turbos and nerite's snails in pretoria or in S.A???
    Because my lokal stores haven't got any (lets just say they don't ever get it in).

    I need a cleaner crew for algae in my 250L tank(got a algae bloom after i added 2 MH 150W each)my tank is running now for 20 months.It's strting to get better i'm doing a 10% Wc Every week.
    Any help would be nice
     
  2. AdS Guest




    to hide all adverts.
  3. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    you can try out our sponsors for the snails.what type of algea are you experiencing lanzo?
     
  4. lanzo

    lanzo Thread Starter Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    BEFORE

    [​IMG]

    AFTER

    [​IMG]

    [​IMG]

    REd algae end hair algae
     
    Last edited by a moderator: 10 Sep 2007
  5. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    whats are po4 readings lanzo?
     
  6. lanzo

    lanzo Thread Starter Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    was 2ppm 4weeks ago now it's close too 1ppm
     
  7. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    mmh..do you have a heavy bioload or do you feed heavy?if so cut down on the amount of food you put in
     
  8. Alan

    Alan Admin MASA Contributor

    Joined:
    4 May 2007
    Posts:
    5,974
    Likes Received:
    119
    Location:
    KZN
    WOW, 1 or 2 ppm for phosphates is high. Are you sure you not giving nitrate readings there. Phosphates should be around the 0.02 mark and nitrates around the 5ppm.
     
  9. lanzo

    lanzo Thread Starter Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    phos sorry 0.02 and now 0.01
    Nitates 5ppm
    aminia 0
    nirite 0
    ph 8.2
    cal 450
     
  10. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    your nitrates are a bit high.do you have a DSB lanzo
     
  11. lanzo

    lanzo Thread Starter Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    Dsb????
     
  12. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    deep sand bed.it helps in lowering nitrate levels
     
  13. lanzo

    lanzo Thread Starter Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    yip!! When i tested my water i didn't clean my fillters for 2 weeks(oops)
     
  14. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    could be one of the reasons.also make sure you got no deadspots in your tank ;)
     
  15. lanzo

    lanzo Thread Starter Sponsor

    Joined:
    10 Sep 2007
    Posts:
    9,396
    Likes Received:
    26
    Location:
    Centurion
    dead spots???
     
  16. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    yip.thats were there is no flow and detritus tends to settle
     
  17. viper357

    viper357 Admin MASA Contributor

    Joined:
    4 May 2007
    Posts:
    27,988
    Likes Received:
    781
    Just out of curiosity, what make of Metal Halide bulbs did you install?
     
  18. phat

    phat

    Joined:
    6 May 2007
    Posts:
    745
    Likes Received:
    2
    Location:
    the slums


    dude you only had an algae break out cause the lights are more intense than what you had before, the nutrients were always there, so the lights didn't cause it just because you have more light
     
  19. Alan

    Alan Admin MASA Contributor

    Joined:
    4 May 2007
    Posts:
    5,974
    Likes Received:
    119
    Location:
    KZN
    Lanzo, how old is your system? Secondly when you said you didn't clean your filters, what filters are you running?
    Mekaeel 5ppm nitrate is fine, remember you do need some nitrate and phosphate for your corals/clams etc.
     
  20. Galibore

    Galibore Retired Moderator

    Joined:
    6 May 2007
    Posts:
    2,829
    Likes Received:
    19
    Location:
    Germiston
    Lanzo, although snails will help a bit, they are not a cure for algae.
     
  21. Afsal

    Afsal

    Joined:
    7 May 2007
    Posts:
    2,318
    Likes Received:
    22
    Location:
    Dbn,Kzn
     
Recent Posts

Loading...
Similar Threads - Turbos nerite's Forum Date
Happy Birthday TurboSnail The Sump 30 Aug 2009