TS2

Discussion in 'Protein Skimmers, Mechanical Filtration' started by Mouse, 22 Sep 2009.

  1. Mouse

    Mouse

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Morning all

    I got myself a new toy this weekend because I dropped and broke my TS1.

    BUT........ it makes one hell of a noise, surely this can't be right?
     
  2. AdS Guest




    to hide all adverts.
  3. mnd123

    mnd123

    Joined:
    5 Mar 2008
    Posts:
    1,753
    Likes Received:
    14
    Location:
    Fourways Gardens
    What makes a a noise Meece? The pump? If so check that the ceramic shaft aint shafted
     
  4. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Yep, the pump. Seems that wheel that has the pin going through it is the noise maker... :(
     
  5. mnd123

    mnd123

    Joined:
    5 Mar 2008
    Posts:
    1,753
    Likes Received:
    14
    Location:
    Fourways Gardens
    strange - so the ceramic shaft is intact?

    Are both rubber end stoppers there otherwise the shaft is loose and the needlewheel will touch the sides of the pump
     
  6. jacquesb

    jacquesb Retired Moderator

    Joined:
    29 May 2007
    Posts:
    17,868
    Likes Received:
    69
    Location:
    Cape Town
    Mouse - is the TS2 brand new? Or 2nd hand? If it is indeed brand new - please take the skimmer/pump back to where you bought it from. And ask them to replace the impeller/impeller shaft (they MIGHT be able to replace only the shaft)....

    Else, if the skimmer is 2nd hand - you will unfortunately to fork out another R100 odd for a new impeller (the shaft alone should be around R30)....
     
  7. mnd123

    mnd123

    Joined:
    5 Mar 2008
    Posts:
    1,753
    Likes Received:
    14
    Location:
    Fourways Gardens
    Oh dearie me Meece, sounds like you have a broken shaft in the pump.

    And before Crispy and the boys get disgusting, let me get outta here :)
     
  8. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Ooh, broken shaft sounds painful :p

    OK, well then it's going right back to where it came from, I only got it on Sunday and it's been noisy since I connected it.

    Or is it "fixable"?
     
  9. mnd123

    mnd123

    Joined:
    5 Mar 2008
    Posts:
    1,753
    Likes Received:
    14
    Location:
    Fourways Gardens
    Just take it back, as Jacques says, replace the impellor and all should be well, they cheap - but if new, get the person you bought it from to replace
     
  10. mnd123

    mnd123

    Joined:
    5 Mar 2008
    Posts:
    1,753
    Likes Received:
    14
    Location:
    Fourways Gardens
    From a girl thats just plain nasty :p
     
  11. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Thanks Jacques, it's brand spanking new and I ain't taking cr*p stock when it's not entirely cheap...
    I'll take it back as soon as I can.

    But let me show my ignorance here... which part is the shaft (NO CRISPY, let's keep it clean :censored:) and which is the impeller?
     
  12. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Well they saying does go: if you can't beat 'em, join 'em!
     
  13. chikaboo

    chikaboo

    Joined:
    2 Jan 2009
    Posts:
    4,980
    Likes Received:
    48
    Location:
    Newcastle - KZN
    hi mouse if you could look at the pump it would be the very centre of the pump - the core of the pump - it looks like an anorexic cigarette
     
  14. mnd123

    mnd123

    Joined:
    5 Mar 2008
    Posts:
    1,753
    Likes Received:
    14
    Location:
    Fourways Gardens
    LMAO

    Meece, it is the centre of the impellor, is a white shaft with two rubber end caps that goes through the centre of the impellor.

    M
     
  15. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Ok well my shaft is PINK ;) and there is no rubber end cap on it... just a tiny little "washer" like you'd get on a screw and nut.

    This conversation is starting to sound really rude :whistling:

    How is it the Mouse's thread always ends up "dirrrrrrty"
     
  16. FransSny

    FransSny

    Joined:
    16 Oct 2008
    Posts:
    5,697
    Likes Received:
    67
    Location:
    Hermanus
    Too much info Mouse ;)

    There should be a little plastic "hood" over your pink shaft...keeps the shaft in polace so to say :whistling:

    This is not a family friendly thread !
     
  17. chikaboo

    chikaboo

    Joined:
    2 Jan 2009
    Posts:
    4,980
    Likes Received:
    48
    Location:
    Newcastle - KZN
    :lol::rofl::lol:
     
  18. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    I guess I'll have to go and see if I can find a hood....
     
  19. FransSny

    FransSny

    Joined:
    16 Oct 2008
    Posts:
    5,697
    Likes Received:
    67
    Location:
    Hermanus
    Mouse on Friday my TS 2 went down the drain...I have an extra "hood" put it in an envelope and post ..second hand though ;)
     
  20. Mouse

    Mouse Thread Starter

    Joined:
    21 Oct 2008
    Posts:
    853
    Likes Received:
    14
    Location:
    Blouberg by the sea
    Aah, cool Frans, really? Thanks man...second hand better than nothing :)

    Can I PM you my address?
     
  21. FransSny

    FransSny

    Joined:
    16 Oct 2008
    Posts:
    5,697
    Likes Received:
    67
    Location:
    Hermanus
    Sure..will chuck in the post then 2 morrow.
     
Recent Posts