Ticking impeller?

Discussion in 'Anything DIY Related' started by Dane, 16 Sep 2010.

  1. Dane

    Dane

    Joined:
    24 Jan 2010
    Posts:
    1,717
    Likes Received:
    42
    Location:
    Fregate Island, Seychelles
    Hey all,

    Just a query - I have found that sometimes a pump will start to make a "ticking" sound - like the tips of the impeller are hitting the side or something. Often it is intermittant, and just turning the pump on or off will solve it. But on one pump on particular it is quite bad

    Does anyone have a suggestion on what to do? Clipping the impeller tips etc?
     
    Last edited: 16 Sep 2010
  2. AdS Guest




    to hide all adverts.
  3. lloyd18

    lloyd18

    Joined:
    26 Jan 2010
    Posts:
    68
    Likes Received:
    0
    Location:
    Big Bay, Cape Town
    Dane, what pump os it as I am having a similar problem with the pump on my skimmer.
     
  4. purevenom

    purevenom

    Joined:
    29 Aug 2009
    Posts:
    20
    Likes Received:
    1
    Location:
    durban
    what sort of pump is it? . . age . . .etc? if it is intermitent, try having a look at the shaft (i take it its ceramic) as it can often over time start wearing a slight groove or trough in it which would make it vibrate intermitently. maybe even a break.
     
  5. lloyd18

    lloyd18

    Joined:
    26 Jan 2010
    Posts:
    68
    Likes Received:
    0
    Location:
    Big Bay, Cape Town
    An OTP2000 it is brand new only been running for 3 weeks and the noise was there from the moment we plugged it in.
     
  6. Dane

    Dane Thread Starter

    Joined:
    24 Jan 2010
    Posts:
    1,717
    Likes Received:
    42
    Location:
    Fregate Island, Seychelles
    Thanks guys,

    It is actually NOT a ceramic shaft. Its a cheap dolphin internal canister. This is actually a pump running on the freshwater tank I set up for my girlfriend. Dolphin F800 i think... Its about a 8 months old now.
     
    Last edited: 17 Sep 2010
  7. HenkHugo

    HenkHugo

    Joined:
    10 May 2007
    Posts:
    3,629
    Likes Received:
    29
    Location:
    Cape Town
    there's a bad batch of OTP pumps out at the moment - contact your LPS they will replace the impeller....
     
  8. FransSny

    FransSny

    Joined:
    16 Oct 2008
    Posts:
    5,697
    Likes Received:
    67
    Location:
    Hermanus
    Would love to see a LPS replace an impeller :whistling: a LFS might :wave2:
     
  9. HenkHugo

    HenkHugo

    Joined:
    10 May 2007
    Posts:
    3,629
    Likes Received:
    29
    Location:
    Cape Town
    LPS = Local Pet Shop :D
     
  10. fly*

    fly* MASA Contributor

    Joined:
    1 Feb 2010
    Posts:
    472
    Likes Received:
    18
    Location:
    Roodepoort, JHB
    Sounds like either the shaft or the rubbers have gone. Have you opened it up to check ?
     
Recent Posts

Loading...
Similar Threads - Ticking impeller Forum Date
Float switch sticking Test Kits, Controllers, Reactors and Dosers 16 Feb 2016
Urgent help needed Green tip anenome not sticking Urgent Help Needed 5 Apr 2015
Sticking Rock General Discussions and Advice 19 Jan 2015
Sticking polysyrene Anything DIY Related 14 Nov 2011
sticking lr together with pratley General Discussions and Advice 3 Apr 2011
Sticking Coral frags with "new" plastic Fragging Corals 25 Apr 2010
Sticking SPS using putty SPS Corals 13 Feb 2009