Stupid question

Discussion in 'Beginner Discussions' started by JDV, 16 Aug 2012.

  1. JDV

    JDV

    Joined:
    5 Dec 2011
    Posts:
    373
    Likes Received:
    6
    Location:
    Cape town
    Hi Guys

    Excuse the stupid question, as you know I am a new boyu tl550 owner, the return pump is very noisy I would like to remove it to check what’s up.
    2 question, are they normally noisy? and how do I remove the pump? I’d rather ask before braking the ting.
     
  2. AdS Guest




    to hide all adverts.
  3. butcherman

    butcherman Moderator MASA Contributor

    Joined:
    7 Sep 2009
    Posts:
    11,626
    Likes Received:
    280
    Location:
    Kempton Park
    im not familiar with the pump. but you should be able to remove it from the tank and atleast clean and/or replace the impelor if needed. or maybe just replace the pump, but first inspect the think i bet a good clean might sort it out
     
  4. JDV

    JDV Thread Starter

    Joined:
    5 Dec 2011
    Posts:
    373
    Likes Received:
    6
    Location:
    Cape town
    I also thought it needs cleaning so now the trick question how do I remove it?
     
  5. mandarinman

    mandarinman

    Joined:
    18 Oct 2007
    Posts:
    6,377
    Likes Received:
    70
    Location:
    capetown,durbanville
    Disconnect the pipe between uv (pipe at top) and pump (at bottom) by pushing middle pipe downwards to disconnect from uv and then pull pump and connecting pipe upwards to remove.
     
  6. JDV

    JDV Thread Starter

    Joined:
    5 Dec 2011
    Posts:
    373
    Likes Received:
    6
    Location:
    Cape town
    ok cool, thanks will try the weekend, wife was home sick yesterday mound about the noise. :p
     
  7. butcherman

    butcherman Moderator MASA Contributor

    Joined:
    7 Sep 2009
    Posts:
    11,626
    Likes Received:
    280
    Location:
    Kempton Park
    Carefully :lol: actually im not sure but once you have it out soak it in a water / vinigar for an hour to clean in really good.
     
  8. crispin

    crispin

    Joined:
    22 Jan 2008
    Posts:
    12,223
    Likes Received:
    160
    Location:
    Lilliehammer, Norway
    once you have the pump out (turn it off BEFORE trying to disconnect it, sounds silly but even Riaan fiorgets these things occasionaly) then dilute vinegar to about 25% sollution and let the pump stand in that for a few hours. Then use a old tooth brush and crean it off, you can often open the pumps so you get to the impellor and thats often the source of noise in pumps. Occasionally (or often in the case of my tanks) you get snails in there which ruin the impellor, or the shaft might have come loose from the outer cover and thus it vibtrates as it turns.

    Check the impellor as thats most often where noise originates
     
  9. JDV

    JDV Thread Starter

    Joined:
    5 Dec 2011
    Posts:
    373
    Likes Received:
    6
    Location:
    Cape town
    Cool, thanks all for the info and help. Will do over the weekend.
     
Recent Posts

Loading...
Similar Threads - Stupid question Forum Date
Really stupid question Beginner Discussions 4 May 2014
A poor newcomer's stupid questions Beginner Discussions 5 Dec 2011
stupid question? Beginner Discussions 9 Aug 2011
Stupid Question Marine Fish Discussions 24 Jul 2009
might be stupid question Water Parameters and Additives 13 Nov 2008
Durso - Stupid question Pumps and Waterflow 5 Sep 2008
Stupid siphoning question General Discussions and Advice 22 Feb 2008