SAGA Solenoid Valve help

Discussion in 'Test Kits, Controllers, Reactors and Dosers' started by Mekaeel, 25 May 2008.

  1. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Hey crew.
    i bought a second hand Saga regulator with solenoid valve.hooked it up but it appears that the relay (little black box) isnt working.the light is comming on,indicating that power is being sent to the unit but the relay isnt ticking and dosing.can somebody give me advice on how to repair this unit.from what i think,i gotta remove the relay and fit a new one.any idea from where i can get one of these.
    thanks
    Mekaeel
     
  2. AdS Guest




    to hide all adverts.
  3. viper357

    viper357 Admin MASA Contributor

    Joined:
    4 May 2007
    Posts:
    27,982
    Likes Received:
    777
    Is it a 12v or 220v relay?
     
  4. Mekaeel

    Mekaeel Thread Starter Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    220V 3 pin relay
     
  5. Reef Maniac

    Reef Maniac MASA Contributor

    Joined:
    15 May 2007
    Posts:
    2,899
    Likes Received:
    112
    Location:
    Bloemfontein
    Hey Mekaeel, you should know by now that you must POST PICTURES so we all can see what you're talking about ...

    If you have a multi-tester you could check the resistance between the live and neutral pins of the relay's plug. If it is very large (over range) then the solenoid coil has probably burnt out and you will have to get a new one (or the wires are not making contact somewhere...).

    Hennie
     
  6. Mekaeel

    Mekaeel Thread Starter Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    hi Hennie,sorry im at my office pc cant upload any pics right now,but will try later.
    i did open up the unit and the light is indicating power.dont have a multimeter,but what i'll do is try and connect 3 wires ie.live neutral and earth directly to the relay and test that way to see if the relay ticks.
     
  7. Mekaeel

    Mekaeel Thread Starter Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    ok,stripped it down.connected the relay directly to a plugpoint,but its dead.no ticking sound.looks like i need another relay :(
     
Recent Posts

Loading...
Similar Threads - SAGA Solenoid Valve Forum Date
SAGA shipment received including regulators, solenoids, level controllers, ph pe... Aquarium Depot 7 Nov 2012
saga auto top up Reef Aquatics 17 Mar 2016
Saga PH moniotr Water Parameters and Additives 31 May 2015
Saga range extended with tweezers, scissors & a maintenance holder Aquarium Depot 20 Jan 2014
Shipments in from ATI & Saga Aquarium Depot 23 Sep 2013
SAGA pH2101C ► Sponsor Request Forum 18 Sep 2013
SAGA Master controller for pH/Redox Test Kits, Controllers, Reactors and Dosers 31 Aug 2013