Rust red filter sock

Discussion in 'Protein Skimmers, Mechanical Filtration' started by jpvd007, 10 Aug 2018.

  1. jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    E9393588-065E-4796-B142-1630BC538B0A.jpeg Hi all
    It’s been a while since posting but all’s been going well till this little problem has come up over the last 2 weeks. This is the second sock change that I have had this happen and I was wondering what is causing this problem. On inspection of the overflow pipe running in to the sock I also found the rust colour slim coating the pipe as well as in other pipes in the protein skimmer the phos reactor and the return pump intake. All of the places it is growing are high flow areas.

    It is not at all in the tank it self only in the no light areas and pipes.

    Is this a form of cyno? Or some other algae.

    The water parameters are as follows
    PH 8
    Phos 0ppm
    Cal 380
    Ammonia 0ppm
    KH 143
    Nitrite 0ppm
    Nitrate 40ppm

    So the nitrate is high but that’s the only one out of whack and when the first sock was red the nitrates at that time were only 5ppm.
     
  2. Guest




  3. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    9621A121-03F2-4C94-A79D-9BAB01DD58E9.jpeg 2308420B-9275-43E0-AA5A-B21F36C7FCA1.jpeg 83755DDC-325B-4FB9-93F6-DA42DB02266C.jpeg
     
  4. leslie hempel

    leslie hempel Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    16,603
    Likes Received:
    897
    Location:
    Gonubie East London
    possibly a pigment from the food you feeding?
     
    pHishman and tekkengal like this.
  5. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    That was my first thought after starting a new coral food just before this happened the first time but that was 4 days after the new feeding and I have not fed it since, would this old food still be in the system two weeks after the feeding? If so that’s crazy.
     
  6. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    8C04C6D4-6060-42B7-9FFE-25F259F530F3.jpeg FA2DA926-D115-4CD0-B83F-515C2E240818.jpeg 1A6B84D6-FA18-474B-90CB-D57070C54C88.jpeg 3F4A2100-ED3A-403B-9AC9-5B246F6AFCDA.jpeg

    Okay so this is what the other parts of the sump look like including the skimmer cup. I am still not convinced it was the food that was fed as This is getting worse over night the reactor was not as full of the red stuff yesterday. I also put a new sock in yesterday and within 6 hours of filtering it looked like this.
     
  7. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    B248A0F7-84C9-4B05-817B-18122740B99A.jpeg
     
  8. Joshua1

    Joshua1

    Joined:
    28 Jul 2014
    Posts:
    509
    Likes Received:
    156
    Location:
    Centurion
    Are you using NSW or are you mixing/buying water?

    Are you dosing anything?
     
  9. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    NSW, Rowaphos in the reactor and I dose with Red Sea reef foundation ABC I have been using this for 1 year nw with no problems.
     
  10. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    The Rowaphos has only been running for 3 months
     
  11. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    M other 120L also runs on the same NSW and no problems there.
     
  12. Joshua1

    Joshua1

    Joined:
    28 Jul 2014
    Posts:
    509
    Likes Received:
    156
    Location:
    Centurion
    Your rowaphos tumbling in the reactor?
     
  13. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    Yes
     
  14. Joshua1

    Joshua1

    Joined:
    28 Jul 2014
    Posts:
    509
    Likes Received:
    156
    Location:
    Centurion
    I have read before that rowaphos gives off a red dust even after thorough rinsing.

    Maybe switch off the rowaphos reactor and see if the situation improves
     
    jclaas likes this.
  15. OP
    jpvd007

    jpvd007

    Joined:
    3 Aug 2012
    Posts:
    54
    Likes Received:
    16
    Location:
    Dunsbourgh,Western Australia
    Thanks I will try what you suggest as I have been told the same thing when buying it.
     
    jclaas likes this.

Recent Posts

Loading...
Similar Threads - Rust filter sock Forum Date
RSS Squat Lobsters and Porcelain Crabs – Fun Nano Crustaceans RSS Feeds 2 May 2017
Frustration with test kits General Discussions and Advice 5 Mar 2017
[wtd] Encrusting Montis Wanted 7 Jan 2017
Ornate butterfly, heniocus and rusty angel Fish Discussions 18 Jun 2016
Urgent help needed Stand Rust Urgent Help Needed 23 Oct 2015
Reefers in Rustenburg? General Discussions and Advice 21 Oct 2015
RSS Write-Up Wednesday: Automation Trust Factor RSS Feeds 5 Aug 2015

Share This Page