Return pump problems

Discussion in 'Pumps and Waterflow' started by shane, 15 Dec 2008.

  1. shane

    shane

    Joined:
    1 Jun 2007
    Posts:
    668
    Likes Received:
    0
    Location:
    durban
    Hi guys,
    I was checking my return pump on Friday night because I have found that the flow seemed to be slowing down. I removed the front cover and found that 4 of the impellor blades are in fact broken off. The pump is a LIFETECH AP 5800 that is pumping 12 000 l/hour. Does anyone know where I can get a new impellor from or who might stock this part?
    Cheers
    Shane
     
  2. AdS Guest




    to hide all adverts.
  3. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    A bit off topic Shane, but why are you using such a big pump as a return? 4ft tank, correct?
    Those pumps come with a year guarantee, should the guarantee still hold, take it back.
     
  4. shane

    shane Thread Starter

    Joined:
    1 Jun 2007
    Posts:
    668
    Likes Received:
    0
    Location:
    durban
    Hi Mekaeel,
    This is on my big tank. I sent you the pics of the new tank that I got when I bought my house, and this pump was running on that tank.This is the first time that I have checked this pump, and if you can remember I posted a thread about my new DSB filter and asked about flow over the DSB.I found that the flow was starting to slow down over the DSB to the point that I was not able to see water movement.
    Will I be able to pop in tomorrow night for some of that cheato?
    Cheers
     
  5. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Oh I see. Yip, you more than welcome to come through. Just give me a call before hand, just to make sure im around ;)
     
  6. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Which means you probably just had one or two blades on the impellor left.
     
  7. shane

    shane Thread Starter

    Joined:
    1 Jun 2007
    Posts:
    668
    Likes Received:
    0
    Location:
    durban
    Thanks mekaeel,
    thats right only 2 blades opposite each other.
    I am surprised that it was still pumping.
    cheers
     
  8. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Very powerful pumps, thats why ;)
     
  9. shane

    shane Thread Starter

    Joined:
    1 Jun 2007
    Posts:
    668
    Likes Received:
    0
    Location:
    durban
    Hello,
    Anyone know where I can get this impellor from?
    Cheers
     
  10. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    Shane, go to Builders Warehouse in Springfield. They stock Lifetech pumps, so im sure they will stock the accessories aswell.
     
  11. Shaun

    Shaun Retired Moderator

    Joined:
    29 Aug 2007
    Posts:
    5,274
    Likes Received:
    15
    Location:
    KZN
    Try Northlands they may have one that will fit.
     
Recent Posts

Loading...
Similar Threads - Return pump problems Forum Date
[wtd] Return pump Wanted Yesterday at 21:07
External Return Pump Pumps and Waterflow 11 Nov 2016
[wtd] DC return pump Wanted 29 Oct 2016
[wtd] Return pump Wanted 26 Aug 2016
[wtd] return pump Wanted 29 Jul 2016
[wtd] Return pump Wanted 30 Jun 2016
[wtd] Return pump 3000l or close Wanted 7 Jun 2016