Resun CL650 maintainance

Discussion in 'Test Kits, Controllers, Reactors and Dosers' started by KevinW, 8 Dec 2007.

  1. KevinW

    KevinW

    Joined:
    6 May 2007
    Posts:
    342
    Likes Received:
    4
    Location:
    Hillcrest
    Hi all,

    I have filed (ie put in a very safe place) all the documentation that came with my chiller. I am having a problem with it in that the temperature it is displaying and operating at is incorrect (out by about 3C). What I am after is information on the maintainance of these chillers and any other advice/comments about this chiller.
     
  2. AdS Guest




    to hide all adverts.
  3. Kanga

    Kanga Retired Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    4,576
    Likes Received:
    23
    Location:
    In the Koeberg blast radius
    I have the same unit , however my temp display died completely, I now just set it up or down as the tank needs
     
  4. KevinW

    KevinW Thread Starter

    Joined:
    6 May 2007
    Posts:
    342
    Likes Received:
    4
    Location:
    Hillcrest
    Hi Kanga, I am not too concerned about the display although it is a pain not being able to rely on it. What I am worried about is that the thermostat is also out.
     
  5. Kanga

    Kanga Retired Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    4,576
    Likes Received:
    23
    Location:
    In the Koeberg blast radius
    Mhh are you having variations then ?
     
  6. KevinW

    KevinW Thread Starter

    Joined:
    6 May 2007
    Posts:
    342
    Likes Received:
    4
    Location:
    Hillcrest
    Starting to. The chiller keeps on kicking in and is starting to work overtime. Tank was running at 26C and is hanged at 24 or so before I switched the chiller off.

    I was wondering it there may be some growth inside the pipework or something that is affecting the thermostat. Still have not got round to opening it up to take a look at where the thermostat is (inside or outside the pipes).
     
  7. Kanga

    Kanga Retired Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    4,576
    Likes Received:
    23
    Location:
    In the Koeberg blast radius

    Let me know:p If you dont break it I will clean mine:lol:
     
  8. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    i know alot of these chillers dont give you an accurate reading.monitor the temp readings using a normal (working) thermometer and then set the temperature according to the thermometer.....if im making any sense
     
  9. Kanga

    Kanga Retired Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    4,576
    Likes Received:
    23
    Location:
    In the Koeberg blast radius
    in otherwords Mekaeel, you are saying that if the chiller is set to, lets say 28, and that is 26 in your tank. A consistent 28 on the chiller will give you a consistent 26 in your tank?

    I would agree, thats the way I see it
     
  10. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    yes that what im trying to say.thank you Kanga :lol:
     
  11. Kanga

    Kanga Retired Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    4,576
    Likes Received:
    23
    Location:
    In the Koeberg blast radius
    You are welcome Kind man.:thumbup:
     
  12. SIMS

    SIMS

    Joined:
    6 May 2007
    Posts:
    3,008
    Likes Received:
    17
    Location:
    Empangeni
    I have the small 150 and it seems to be correct. Clinton sold me some of those digital thermometers and he got em check to see if they correct and my chiller is out by maybe .5 degree...

    I wonder if running it on a controller would be a better idea?
     
  13. KevinW

    KevinW Thread Starter

    Joined:
    6 May 2007
    Posts:
    342
    Likes Received:
    4
    Location:
    Hillcrest
    Hi Mek,

    I know that you cannot rely on the accuracy of the temp readout on the chiller and that you (often) have to use a correction factor. The temp readout on my chiller is currently set to kick in at 29C to correct for this. The problem that I have is that the chiller is now starting to kick in even if the water temp is OK.
     
  14. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    my Haliea 300 does the same,also switches on and off.pretty normal as far as i know,and keeps my water temperature quite stable
     
  15. KevinW

    KevinW Thread Starter

    Joined:
    6 May 2007
    Posts:
    342
    Likes Received:
    4
    Location:
    Hillcrest
    Hi Mekaeel,

    Sorry - I am obviously not explaining myself very well. The chiller is operating as usual in that the thermostat is kicking in when the water temp increases and shutting down when it cools. The problem is that, even though it is set to kick in at 27C (display temp on the chiller of 29C), it is now kicking in at a water temp a lot lower than that. This is what makes me think that the thermostatic switch is either faulty or (if it is in the piping) it has some growth on it. Hence my request for info on servicing.
     
  16. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    ok get you now.check out the temperature probe on the chiller to see if its plastic or titanium.if its plastic,im sure thats your problem,change it to a titanium probe.thats what i had to do on my chiller and now all sorted
     
  17. KevinW

    KevinW Thread Starter

    Joined:
    6 May 2007
    Posts:
    342
    Likes Received:
    4
    Location:
    Hillcrest
    Well opened it up and it is, without some serious dismantling of insulation, impossible to get to the thermostat. Checked inside the inlet and outlet and it looked fairly clean so I just flushed the system with lots of fresh waster and put it all back together. Will try running it again to see if that made any difference (although my system is sitting very happily at 26C without it at present). Otherwise anyone know who the agents are in SA?
     
  18. Kanga

    Kanga Retired Moderator MASA Contributor

    Joined:
    7 May 2007
    Posts:
    4,576
    Likes Received:
    23
    Location:
    In the Koeberg blast radius
    Koi Country in PE I believe are the Agents for SA

    Although I could be wrong
     
Recent Posts

Loading...
Similar Threads - Resun CL650 maintainance Forum Date
Resun Cl650 chiller Test Kits, Controllers, Reactors and Dosers 26 May 2007
Resun sp 3800l return pump General Discussions and Advice 8 May 2016
[wtd] Resun Waver 15000a Controller Wanted 4 Feb 2015
[wtd] Resun Waver 2000 Wanted 5 Oct 2014
[wtd] Resun Wavemaker 15000 pumps Wanted 11 Feb 2013
Resun PC-18000 suitable for marine use? Pumps and Waterflow 17 Dec 2012
Help with RESUN CL-200 chiller General Discussions and Advice 3 Nov 2012