Protien Separator/Skimmer not working

Joined
19 Apr 2008
Posts
1,191
Reaction score
10
Location
Tokai, Cape Town
Hi Guys,

After disasembling my protien separtor I think I messed it up ? The white magentic wheel I think should be spinning, is this correct ?

I cannot set this to balance on the magenetic field properly, could someone please shed some light ?

BTW i have a boyu nano TL-550?

Please help? Can someone explain it correct functionality and assembly

Cheers
 
Joined
19 Apr 2008
Posts
1,191
Reaction score
10
Location
Tokai, Cape Town
hmmmm, buggers, they must have fell into the tank ??? Let me try to find them ?

Could they have popped out easily ?

Thanks for the fast reply :)
 
Joined
19 Apr 2008
Posts
1,191
Reaction score
10
Location
Tokai, Cape Town
O dont think i can find this, probably as I dont know what I'm looking for ? Could you send me a link if someone dismantled it already ?
 

Alan

Admin
Joined
4 May 2007
Posts
5,974
Reaction score
123
Location
KZN
There should be the rubber supports as well as 2 plastic washers that fit on the shaft either side of the impeller assembly. Have never seen this skimmer just going of what most pumps have. The rubber parts are little cups that hold the impeller in place and fit at either end of the metal/ceramic shaft. The plastic washers are bearings that fit between the impeller assembly and the rubber holders.
WOW just re read my post and hope it makes sense.
 
Joined
19 Apr 2008
Posts
1,191
Reaction score
10
Location
Tokai, Cape Town
ohhhh no now its broke, I can smell some burn and the electric tripped ???? Where could I find another one ???

Please help ???
 
Joined
8 May 2008
Posts
331
Reaction score
0
Location
cape town
shit, take it to your lfs and ask them, or be sneaky and say that it just burnt out on you, and they can send it away.. ;)
 
Joined
2 Jun 2008
Posts
2,420
Reaction score
15
Location
Cape Town
ohhhh no now its broke, I can smell some burn and the electric tripped ???? Where could I find another one ???

Please help ???
That's hectic Sammy!! As Robski asked. why were you taking it apart in the first place?? Isn't your tank still cycling? Surely it didn't need that kind of maintence yet?
 
Joined
19 Apr 2008
Posts
1,191
Reaction score
10
Location
Tokai, Cape Town
Got a new one from LFS, where it was emhasized as to what a great favour he has done me ??? This system should be under gaurentee i would think ???? Anway all seem ok now, tank now reaching 4 weeks into cycle ...
 
Joined
10 May 2007
Posts
3,629
Reaction score
29
Location
Cape Town
Sammy it is under warrenty.... if the shop gives you hell let me know.... i know the guys that import it very well.
 

Top