Problem with lighting TL550 LED ver

Discussion in 'Boyu TL450 and TL550 advice' started by red deacon, 11 Nov 2014.

  1. red deacon

    red deacon

    Joined:
    20 Jul 2014
    Posts:
    447
    Likes Received:
    109
    Location:
    Gauteng
    Hi guys

    So I have a problem with the white lighting on my unit. Blue lights working perfectly but the white lights are flicking on and off for long periods before engaging fully. I also have periods where the white lights go out on their own.Any ideas what the problem could be? The lights are sealed and nothing has been done to them. Thanks
     
  2. Guest




  3. Andre@ReefAquatics

    Andre@ReefAquatics Sponsor

    Joined:
    18 Dec 2012
    Posts:
    2,721
    Likes Received:
    161
    Location:
    Durbanville
    return it to your supplier, they should replace it, I don't think repairs are done locally boyu locally.
     
  4. OP
    red deacon

    red deacon

    Joined:
    20 Jul 2014
    Posts:
    447
    Likes Received:
    109
    Location:
    Gauteng
    I wish it were so simple Andre. I am hoping someone has had a similar problem and can point me in the right direction. Failing that I will be calling in a favour from my boet who is an electrical engineer to come check it out
     
  5. Andre@ReefAquatics

    Andre@ReefAquatics Sponsor

    Joined:
    18 Dec 2012
    Posts:
    2,721
    Likes Received:
    161
    Location:
    Durbanville
    ahhhh ok, no more questions, well to me and the problem you explain seems more like a driver problem, if your boet is a Elec Eng he will know what to do.

    In most cases a led blows open and all other leds in the circuit stops working, hence sounds like a driver issue.
     
    Last edited: 11 Nov 2014
  6. Reaper

    Reaper

    Joined:
    15 Jun 2007
    Posts:
    1,117
    Likes Received:
    50
    Location:
    Kuilsriver - Western Cape
    keep us posted on the progress and the outcome - I have the same unit working beautifully
     
  7. OP
    red deacon

    red deacon

    Joined:
    20 Jul 2014
    Posts:
    447
    Likes Received:
    109
    Location:
    Gauteng
    So having an electrical engineer in the family has its advantages ;). The problem is the driver as Andre suspected. My boet stripped the LED cover and identified two possible culprits, either the switch itself or the driver. Once the lighting started playing up again the driver was identified as the culprit.

    @Andre@ReefAquatics do you stock any of these parts or could you point me in the right direction please.
     
    Last edited by a moderator: 26 Nov 2015
  8. Andre@ReefAquatics

    Andre@ReefAquatics Sponsor

    Joined:
    18 Dec 2012
    Posts:
    2,721
    Likes Received:
    161
    Location:
    Durbanville
    Send me the spec, we are working on a retrofit for the TL550 and sourcing components I can squeeze u in
     

Recent Posts

Loading...
Similar Threads - Problem lighting TL550 Forum Date
Lighting problems Lighting 30 Sep 2009
Lighting problems Lighting 2 Apr 2008
The Problems of Having Healthy Fish General Discussions and Advice Today at 12:40
Monsker 3500 skimmer problem Protein Skimmers, Mechanical Filtration 8 Mar 2017
Zet ZG5200 LED problem Lighting 16 Jan 2017
How I feel you could run an immune, natural tANK FOR 40 YEARS WITH FEW PROBLEMS Advanced Topics 14 Jan 2017
Anyone having a problem posting pics ? Forum Suggestions and Feedback 10 Dec 2016