Please Help with viaaqua SK-388 2

Discussion in 'Protein Skimmers, Mechanical Filtration' started by bhupesh.mandewal, 8 Oct 2011.

  1. bhupesh.mandewal

    bhupesh.mandewal

    Joined:
    6 Oct 2011
    Posts:
    7
    Likes Received:
    0
    Location:
    india
    I bought this skimmer a month back installed it and yet its not forming form..
    its working since 4 weeks and not forming form
    im bit frustrated tried all setting but still its not working.
    please help me...

    my tank size abt 70 g with sump and i have only one electric damsel and some button polys
    i have started tank yet so its not yet stocked much..
     
    Last edited: 8 Oct 2011
  2. AdS Guest




    to hide all adverts.
  3. Suhayl

    Suhayl

    Joined:
    24 Sep 2007
    Posts:
    1,230
    Likes Received:
    18
    Is it making bubbles? Post some pics please of the skimmer installed.
     
  4. bhupesh.mandewal

    bhupesh.mandewal Thread Starter

    Joined:
    6 Oct 2011
    Posts:
    7
    Likes Received:
    0
    Location:
    india
    i will post some pics in 2 days
    today the form formed but only for some time

    and yup it makes bubbles but only till where the water level is there
     
  5. Tremayn

    Tremayn

    Joined:
    21 Mar 2010
    Posts:
    5,226
    Likes Received:
    69
    Location:
    Lenasia
    how old is your tank? How long did you wait before you introduced live stock? Was the skimmer brand new when you got it? Are the bubbles fine?
     
  6. bhupesh.mandewal

    bhupesh.mandewal Thread Starter

    Joined:
    6 Oct 2011
    Posts:
    7
    Likes Received:
    0
    Location:
    india
    bubbles are fine and my tank is 2 month old its not having much bio load is it the reason of my skimmer not working it works sometimes only means once in 20 times
     
  7. Tremayn

    Tremayn

    Joined:
    21 Mar 2010
    Posts:
    5,226
    Likes Received:
    69
    Location:
    Lenasia
    it is possible that there is not enough of a bio load.. Do you have pics?
     
  8. bhupesh.mandewal

    bhupesh.mandewal Thread Starter

    Joined:
    6 Oct 2011
    Posts:
    7
    Likes Received:
    0
    Location:
    india
    this are the pics of the skimmer

    [​IMG]

    the bubbles are fine but the form doesnt from more than the neck
    [​IMG]

    [​IMG]



    [​IMG]
     
    Last edited: 9 Oct 2011
  9. Drk

    Drk

    Joined:
    18 Aug 2009
    Posts:
    308
    Likes Received:
    0
    Location:
    Lydenburg
    I have the same skimmer it look fine to me i think the bio load of your tank is not that high. what live stock do you have in the tank?
     
    Last edited: 9 Oct 2011
  10. bhupesh.mandewal

    bhupesh.mandewal Thread Starter

    Joined:
    6 Oct 2011
    Posts:
    7
    Likes Received:
    0
    Location:
    india
    one electric damsel and 12 pieces of polys.
    my water in tank and sump comes around 70gallon..
     
  11. Falcon

    Falcon

    Joined:
    26 Feb 2008
    Posts:
    2,869
    Likes Received:
    31
    Location:
    VEREENIGING
    seems like your bio load is still low....give it a few weeks or check again once you have more fish.....
     
Recent Posts

Loading...
Similar Threads - Please Help viaaqua Forum Date
Overflow fitting help please Pumps and Waterflow 30 Nov 2016
Please help ORI with the KZN bait collection survey Diving, Collecting and Environmental Discussions 11 Nov 2016
Urgent help needed Please help/ fish looks like its dying Urgent Help Needed 7 Nov 2016
Please Help Id this Surgeon ID Needed 15 Aug 2016
Help please Quarantine Tanks, sick fish, QT corals 4 Aug 2016
Help please auto top up Beginners 30 Jul 2016
Please help I'D whatever this is. ID Needed 24 Jul 2016