OR2500 Please Help?

Joined
6 May 2007
Posts
3,008
Reaction score
17
Location
Empangeni
Hello

My problems seem to be never ending. My OR2500 skimmer pump keeps tripping the power. I have changed the plug and same problem. It looks like the blue wire is burned although it could just be different color wire but I don't know. Has a fairly new impellor and shaft. Not modded.

any ideas where/how I can get it fixed?

Thanks
 

Alan

Admin
Joined
4 May 2007
Posts
5,974
Reaction score
123
Location
KZN
Sorry my bad, the only thing you can do is get it to NP in the morning.
 
Joined
6 May 2007
Posts
3,008
Reaction score
17
Location
Empangeni
skimmer :lol: the same pump I got from you just changed the impellor and shaft a few months ago. Tell me do they fix pumps or just chuck em away as I see the one side is completly sealed?
 

Alan

Admin
Joined
4 May 2007
Posts
5,974
Reaction score
123
Location
KZN
The only thing they can repair or replace is the impeller if the pump itself is faulty, then they toss it. I know NP have a ATI 2200L at the moment for about R800.00, absolutely stunning pump. Where did you get the impeller from?
 
Joined
6 May 2007
Posts
3,008
Reaction score
17
Location
Empangeni
Got it from Northlands. You think it's a wise idea changing the pump to another brand on the skimmer?
 

Alan

Admin
Joined
4 May 2007
Posts
5,974
Reaction score
123
Location
KZN
Sorry, i forgot you have the TF 1000, i would get hold of Milli and get the reef octo needle wheel pump 3000L, far cheaper than the AM. You may just have to make up a venturi for it, not a big problem that.
 

Similar threads


Top