Odessea Light

Discussion in 'Beginner Discussions' started by Raboebi, 27 Aug 2012.

  1. Raboebi

    Raboebi

    Joined:
    10 Aug 2012
    Posts:
    76
    Likes Received:
    0
    Location:
    Centurion
    Hi Guys,

    I have the Quad 24W Odessea light and I noticed that after the lights are switched off that the blue light flashes every now and again. Is this common? Is the light faulty?

    Any help on offer?

    Kind regards,

    Rabz
     
  2. Guest




  3. Gary Roebuck

    Gary Roebuck

    Joined:
    12 Jul 2011
    Posts:
    476
    Likes Received:
    2
    Location:
    Vereeniging SA
    u have an earth fault / loose or no earth on the light fitting. best u sort it quick. electronic ballasts need earth as a reference or u could end up replacing it !
     
  4. LCornelius

    LCornelius Moderator

    Joined:
    5 Mar 2009
    Posts:
    5,548
    Likes Received:
    140
    Location:
    Durbanville (CPT)
    It is a known issue with these units, mine does the same.

    It does not bother me, looks like lightning :)
     
  5. Jayceew

    Jayceew

    Joined:
    20 May 2011
    Posts:
    721
    Likes Received:
    9
    Location:
    Pretoria East
    Mine did the same when I just bought them, about a year and a half later and I cant remember when last I saw them doing this.

    How old are your units?
     
  6. Keanan

    Keanan 2time

    Joined:
    16 Mar 2010
    Posts:
    2,517
    Likes Received:
    26
    Location:
    Cape Town
    Mine does the same, its a known problem with them.
     
  7. OP
    Raboebi

    Raboebi

    Joined:
    10 Aug 2012
    Posts:
    76
    Likes Received:
    0
    Location:
    Centurion
    Brand spanking new :eek:
     
  8. JohnDoe

    JohnDoe

    Joined:
    26 Feb 2010
    Posts:
    355
    Likes Received:
    2
    Location:
    Kraaifontein, Cape Town
    Had one over my tank that did the same. Unit still works, just replaced it with a DIY LED build.
     
  9. OP
    Raboebi

    Raboebi

    Joined:
    10 Aug 2012
    Posts:
    76
    Likes Received:
    0
    Location:
    Centurion
    DIY LED Build? Any specs?
     
  10. Jayceew

    Jayceew

    Joined:
    20 May 2011
    Posts:
    721
    Likes Received:
    9
    Location:
    Pretoria East
    Mine only did this when they were relatively new, cant remember seeing it happen again lately.
     
  11. JohnDoe

    JohnDoe

    Joined:
    26 Feb 2010
    Posts:
    355
    Likes Received:
    2
    Location:
    Kraaifontein, Cape Town
    24 x 3W Bridgelux (12 White + 12 blue split). Meanwell drivers

    You can check out my thread for pics.
     
  12. OP
    Raboebi

    Raboebi

    Joined:
    10 Aug 2012
    Posts:
    76
    Likes Received:
    0
    Location:
    Centurion
    Got the ballasts exchanged, lights seem to be working just fine now.
     
    Last edited: 28 Aug 2012

Recent Posts

Loading...
Similar Threads - Odessea Light Forum Date
RSM Lights RSM Red Sea Max tanks Yesterday at 10:44
Zetlight Led special this week ZT6600 and ZT6800 DONT MISS OUT!!! Sponsor Specials Tuesday at 12:24
[wtd] Zetlight 1201 with Controller or Equivalent Wanted Monday at 17:02
LED light Vertex New Members 5 Jul 2017
Mushroom coral too much lighting? General Discussions and Advice 1 Jul 2017
[wtd] Moonlight LED's Wanted 28 Jun 2017
[wtd] zetlight ZG5200 Wanted 27 Jun 2017