No3 and Po4 read 0 but algae grows

Joined
1 Apr 2012
Posts
111
Reaction score
13
Need some help identifying this algae. Started off looking like GHA, but gets dusty brown with bubbles. Is it Dinoflagellates?
210308

210309
210310
 
Last edited:
Joined
9 Sep 2018
Posts
202
Reaction score
60
Looks pretty much like the same stuff I had in my tank just after cycling. Not sure what it is but it eventually died out without me doing anything
 
Joined
1 Apr 2012
Posts
111
Reaction score
13
Any more advice?
Still battling. Feel like my tank is on the edge of a crash.
Lps corals are starting to strip now too

210591

210590
 
Last edited:
Joined
25 Nov 2016
Posts
458
Reaction score
173
Location
JHB
that first pic with the chalice. that is bubble algae. a REAL pain in the ass. You can manually remove them but make sure not to pop the pods in the tank. Or you can try an emerald crab.

The brown slime type algae I also got when cycling a new tank. eventually goes away when your tank stabilizers. but it helps to keep siphoning it out each time you do a water change.
 
Joined
23 Feb 2010
Posts
4,085
Reaction score
195
Location
Cape Town
Does look like dinoflaglettes. Hopefully I'm wrong coz they a pain to get rid of.. They can come out in uln systems
 
Joined
25 Nov 2016
Posts
458
Reaction score
173
Location
JHB
Does look like dinoflaglettes. Hopefully I'm wrong coz they a pain to get rid of.. They can come out in uln systems
Hopefully not, and unfortunately only way to know for sure is to put it under a microscope to identify which strain of Dino you have
 
Joined
1 Apr 2012
Posts
111
Reaction score
13
Yeah I think I let my nutrients fall too low, now I’m sitting with a big problem
 

Top