Urgent help needed Nennie not happy

Joined
4 Dec 2013
Posts
636
Reaction score
47
Location
Johannesburg
My Magnificent Anemone started going limp two weeks ago, after my clam sucked up a snail in its base and couldn't open and died. I did two 50% water changes, the weekend before last when it happened, and last weekend as well, Nitrates were on 10. I think I was also underfeeding it which didn't help, but I fed it twice this week.
The clown is trying to get it to pump up but it is not really doing anything. I have only checked nitrates so far and they were on 10, and I have just done a 14% water change now. I have been moving the position of the flow pump to try and ensure it gets a reasonable water movement, but have only done this since it started hanging. For the two weeks before this when I put it in the tank, it was happy.
Are there any obvious reasons why it would still be sulking?

20160221_150533 (Medium).jpg
 
Joined
4 Dec 2013
Posts
636
Reaction score
47
Location
Johannesburg
Temp 26
Salinity 1.025
Nitrates 10, but I have just done a 14% water change.
I have got a Vertex SR260 light
I have not checked the other parameters yet, I thought I would see if there was an obvious reason first.
 

viper357

Admin
Joined
4 May 2007
Posts
29,858
Reaction score
1,392
I think you may have a bit of an Ammonia and/or Phosphate issue with the clam dying. Anemone's are very sensitive to changes in water parameters and take a while to recover. Are you running carbon?
 

Similar threads


Top