my skimmer is not workin on my 90 litre nano tank????

webber

Copepod
Joined
6 Jan 2009
Posts
36
Reaction score
0
Location
somerset
my skimmer has not been working since ive had my tank i have a 90 litre nano tank any answers to this
 

Mike

Retired Moderator
Joined
12 May 2007
Posts
7,859
Reaction score
31
Location
the Motherland
When you say it isn't working, what isn't it doing? what skimmer is it? and do you know how to adjust the air and water levels?
 

webber

Copepod
Joined
6 Jan 2009
Posts
36
Reaction score
0
Location
somerset
no water is in there at all umm i havent got that accesorie i spoke to the man about it becuase wehen i bought it it didnt come in the box so he said he will sort 1 out fr me but he said u cn stuff the outlet with the filter sponge and it will work bt done that and not working. it just the standard one that comes with the nano built in skimmer
 

Mike

Retired Moderator
Joined
12 May 2007
Posts
7,859
Reaction score
31
Location
the Motherland
Need a pic mate, sounds like the bloke you got it from is talking rubbish.
 

leslie hempel

Sponsor
Joined
7 May 2007
Posts
17,087
Reaction score
1,012
Location
Gonubie East London
more info please what skimmer is it? please post a pic and perhaps we can suggest somthing that can be done DIY style untill the part arrives...
 

jacquesb

Retired Moderator
Joined
29 May 2007
Posts
17,868
Reaction score
71
Location
Cape Town
Hi Webber - the basic working of a skimmer is like this:
- water is pumped into the skimmer body, and at the same time air is either sucked in (by the same pump pumping the water into the skimmer body), OR by a seperate pump...
- the air then mixes with the water, to create millions upon millions of tiny tiny tiny bubbles...
- these bubbles then flows upwards, towards the top - as the bubbles flow upwards, they grow bigger and bigger, collecting protein's and other crap out of the water.
- the "crap" then accumulates in the top/skimmer cup...

Now - you must try and find out whether your pump is not working correctly, that's connected to the skimmer.
OR, IF the pump is indeed working, the air-pipe might be clogged up - try and blow a breath through the pipe where the air is sucked through - see if you see the bubbles coming out inside of the skimmer body.....
There should be bubbles at least - in your pic, I do not see any bubbles....
IF we can get the bubbles to work correctly, then we can look at sorting the water levels....

Good luck.
 

Mtroboer

Chromis
Joined
7 Mar 2008
Posts
639
Reaction score
5
Location
Kimberley
To me it also seems like it's not foaming?! Do as Jacques says and see if the air line isn't clogged.
 

Similar threads


Top