My new redsea build

Joined
22 Jun 2019
Posts
86
Reaction score
29
Hopefully I get a chance to set it up in December
 
Joined
22 Jun 2019
Posts
86
Reaction score
29
Hi all its been a long wait .tank finally arrived what a beautiful tank. Started assembly few days ago everything going slow for now just want to take my time and set up everything properly.
 

Attachments

  • IMG-20220418-WA0000.jpg
    IMG-20220418-WA0000.jpg
    81 KB · Views: 71
  • IMG-20220418-WA0003.jpg
    IMG-20220418-WA0003.jpg
    107.4 KB · Views: 70
  • IMG-20220418-WA0004.jpg
    IMG-20220418-WA0004.jpg
    65.2 KB · Views: 73
  • IMG-20220418-WA0005.jpg
    IMG-20220418-WA0005.jpg
    73.3 KB · Views: 77
  • IMG-20220418-WA0007.jpg
    IMG-20220418-WA0007.jpg
    68.3 KB · Views: 77
Joined
15 Apr 2021
Posts
35
Reaction score
14
Hi all its been a long wait .tank finally arrived what a beautiful tank. Started assembly few days ago everything going slow for now just want to take my time and set up everything properly.
Love that scape! Perfect way to show off those sps
 
Joined
17 Aug 2016
Posts
72
Reaction score
16
Location
Benoni
Wow that is a dam nice setup, enjoy the journey! I will be following it closely. Want to see how the Radion's perform as I need to upgrade my center light with either Radion XR30 Gen 5 or Neptune Sky.
 
Joined
22 Jun 2019
Posts
86
Reaction score
29
Added skimmer and filter roller
 

Attachments

  • 20220420_172229.jpg
    20220420_172229.jpg
    85.1 KB · Views: 65
Joined
22 Jun 2019
Posts
86
Reaction score
29
water finally in
 

Attachments

  • 20220501_204725.jpg
    20220501_204725.jpg
    69.6 KB · Views: 30
Joined
22 Jun 2019
Posts
86
Reaction score
29
Fish finally back home
 

Attachments

  • 20220507_185823.jpg
    20220507_185823.jpg
    78.2 KB · Views: 72
  • Screenshot_20220507-233402_Gallery.jpg
    Screenshot_20220507-233402_Gallery.jpg
    80.9 KB · Views: 69
  • Screenshot_20220507-233405_Gallery.jpg
    Screenshot_20220507-233405_Gallery.jpg
    81.1 KB · Views: 70
  • Screenshot_20220507-233419_Gallery.jpg
    Screenshot_20220507-233419_Gallery.jpg
    83.6 KB · Views: 69
Joined
30 Jun 2012
Posts
892
Reaction score
10
Location
Cape Town
Looking great @Gav1 :thumbup:. Definitely following along on the journey :) :1:
 
Joined
22 Jun 2019
Posts
86
Reaction score
29
Hi guys just some advice needed. At the moment I have 3 gen 5 pro's and just feel like its lacking some color. Should I add 2 led 90's or add 2 orphek blue plus.
2.tested nitrate today @ 1.4 ppm and phosphate 0.14ppm Should I do a 50 % water change tank running for 12days now.
 
Joined
30 Jun 2012
Posts
892
Reaction score
10
Location
Cape Town
Hi guys just some advice needed. At the moment I have 3 gen 5 pro's and just feel like its lacking some color. Should I add 2 led 90's or add 2 orphek blue plus.
2.tested nitrate today @ 1.4 ppm and phosphate 0.14ppm Should I do a 50 % water change tank running for 12days now.
I've been out of the game for quite some time, so please do take what I say with a pinch of salt.

Nitrates @ 1.4ppm sound pretty normal to me, some people prefer to run them much higher than that, even as high as 10 - 20 ppm. As for the phosphate, that is a little high, and you might actually start seeing some algae blooms - you're a big fan of RedSea already :tt2: so maybe grab yourself some RedSea NO3PO4-X.

Since your tank is only running for 12 days now, you might actually be going through the normal Nitrogen Cycle, so I would say rather keep a closer eye on your Ammonia & Nitrite levels, as those are toxic to fish. :swim:

As for what your Nitrate & Phosphate levels should be, I see there are a lot of varying opinions on it, etc. Maybe one of the more experienced guys like @RiaanP or @viper357 could chime in :m16:
 
Last edited:

RiaanP

Moderator
Joined
11 Aug 2008
Posts
26,737
Reaction score
2,444
Location
Centurion
wow... slow down...
Tank got water 10 days ago. Rock was dry, so you got NO bacterial filtration at the moment. Yet you already added 6 fish in there. Just wait. Like another month before adding anything else.

And a 50% water change is a bit extreme. You need to ensure that the water is the same temperature, salinity and PH. Else you will kill your fish when you suddenly change all those parameters too quickly. Alternative would be to slowly add the new water, like in a tap that is almost closed, not dripping but yet not running. Should take you an hour to refill. It is exactly like acclimatizing your fish, but instead of the fish in bags and you add a bit of water slowly, they are now in a much bigger bag (tank) and you are adding water slowly.

And wait with the corals. another month to 6 weeks. Let your tank stabilize first over the next couple of weeks. Slight overfeeding, too many new fish, no filtration yet, and you are in for a bumpy ride for the next few weeks.

Just take it slow.
 
Joined
11 Jul 2011
Posts
1,599
Reaction score
982
Hi guys just some advice needed. At the moment I have 3 gen 5 pro's and just feel like its lacking some color. Should I add 2 led 90's or add 2 orphek blue plus.
2.tested nitrate today @ 1.4 ppm and phosphate 0.14ppm Should I do a 50 % water change tank running for 12days now.
Re. Your lights, why not tweak your schedule you currently have? In my experience, the light mixing from the bars is not ideal. If I had the money I'd have added more units of my current light units and then tweak the schedule on those to get the color you're looking for... May I ask if you're running the xr30s or 15s?
 
Joined
22 Jun 2019
Posts
86
Reaction score
29
Added 100l from my 102 and about 35kg of live rock in the sump and using bio s
 
Joined
22 Jun 2019
Posts
86
Reaction score
29
Hi guys just update and some help needed. Tested the tank today and found kh at 5.1.calc at 240.mag at 880 and did it a few times and same results .I really thought I forgot how to use the test kit.
So mixed up 100l of redsea coral pro and kh at 12.
I don't know what could drop those elements so low.any idea?
Should I mix up some of the salt that was used initially in the tank mb it was not right in the first place.
 
Joined
11 Jul 2011
Posts
1,599
Reaction score
982
And what schedule are you using? Easy to tweak the schedule to suit your preference...

Hi guys just update and some help needed. Tested the tank today and found kh at 5.1.calc at 240.mag at 880 and did it a few times and same results .I really thought I forgot how to use the test kit.
So mixed up 100l of redsea coral pro and kh at 12.
I don't know what could drop those elements so low.any idea?
Should I mix up some of the salt that was used initially in the tank mb it was not right in the first place.
Maybe also check the expiration date on your test kit. They do have a shelf life...
 
Top Bottom