My ATI Sunpower not turning on?????????

Discussion in 'General Discussions and Advice' started by HoboHoppy, 8 May 2014.

  1. HoboHoppy

    HoboHoppy

    Joined:
    8 Apr 2014
    Posts:
    408
    Likes Received:
    5
    Location:
    Edenvale
    Hi Guys

    This morning I noticed my newly acquired 6x24w ATI did not turn on. On closer inspection the blue LCD panel on the front of the unit was blue but no LCD's on display. The fans are also running.

    Do these units perhaps have a fuse that could have blown?
     
  2. AdS Guest




    to hide all adverts.
  3. RiaanP

    RiaanP Moderator

    Joined:
    11 Aug 2008
    Posts:
    23,155
    Likes Received:
    1,229
    Location:
    Centurion
    fuse, if all the lights are out.
    or if only 2 tubes are out, more likely one of the ballast units is faulty
     
  4. HoboHoppy

    HoboHoppy Thread Starter

    Joined:
    8 Apr 2014
    Posts:
    408
    Likes Received:
    5
    Location:
    Edenvale
    None of the lights are coming on. Should I strip the unit?
     
  5. RiaanP

    RiaanP Moderator

    Joined:
    11 Aug 2008
    Posts:
    23,155
    Likes Received:
    1,229
    Location:
    Centurion
    Only option I think.

    But first, just switch it off and on again. And check the timer settings. Maybe the timer is in the off period.
     
  6. HoboHoppy

    HoboHoppy Thread Starter

    Joined:
    8 Apr 2014
    Posts:
    408
    Likes Received:
    5
    Location:
    Edenvale
    That's what I was worried about. I might take it to an electrician rather. The timer is fine I checked it on another light. Cool just wanted to check if there are fuses in the unit.

    Thanks Riaan.
     
  7. irie ivan

    irie ivan MASA Contributor

    Joined:
    6 May 2007
    Posts:
    3,149
    Likes Received:
    171
    Location:
    Bracken
    Newly aquired? Second hand? Warrantee?
     
  8. HoboHoppy

    HoboHoppy Thread Starter

    Joined:
    8 Apr 2014
    Posts:
    408
    Likes Received:
    5
    Location:
    Edenvale
    I bought it on the forum 3 weeks ago.
     
Recent Posts

Loading...
Similar Threads - Sunpower turning Forum Date
[wtd] ATI T5 8 x 80 Powermodule or Sunpower Wanted 8 Apr 2016
[wtd] ATI sunpower lcd Wanted 22 Dec 2015
random info on ati sunpower units Lighting 13 Jan 2015
[wtd] Ati sunpower Wanted 10 Dec 2013
Returning New Members 12 Sep 2016
Sps turning white SPS Corals 16 Aug 2016
Substrate turning green Nuisance Algae 30 Jun 2016