MH doesnt want to turn on

Discussion in 'Lighting' started by mytank, 25 Sep 2011.

  1. mytank

    mytank

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    Hi all

    I know this is a shot in the dark (no pun intended) but MH light was working PERFECTLY - needed to be replaced and replaced a Oddesy 10000k light with a Dyanamax 14k light both 150W, So I turned off the unit waited for it to cool down and then went into replacing the bulb. Was super careful used a tissue etc etc and then turned the light on. Hmmmm no MH came on... my T5's came on but nothing else.

    So I thought new bulb can take its time to ignight so I left it for an hour NOTHING.

    So I played around turned the bulb around etc ever played with the bulb moving it whilst it was on to see if it would ignight - NOTHING....

    Ok so put the old bulb back in. Sh1t also now the old light doesn't come on either. Also left it for 1 hour "on" nothing. I then turned it OFF for 2 hours to see if it needed to "reset" - Still nothing....

    I have no idea what is going on. I am sure there is power as the MH are linked to fans and the fans come on..... just the MH doesn't.

    Anyone know what I can look for?
     
  2. AdS Guest




    to hide all adverts.
  3. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    @dallasg - do you know if there is a local JHB guy that can look \ repair this before I leave on Wed???
     
    Last edited by a moderator: 26 Nov 2015
  4. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    Bud, check if there might be an arc build up on the contact points on the fitting itself?
     
  5. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    I checked they looked pretty clean to me.... do I need to clean them - yup I am panicking I am going away for three weeks :(
     
  6. Electrician24

    Electrician24

    Joined:
    12 Aug 2011
    Posts:
    521
    Likes Received:
    9
    Location:
    Goodwood Cpt
    Check the pin inside the screw fitting, sometimes it does not make proper contact.
    O and switch off light before you do.:wacko:
     
  7. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    suggestion, do this without holding me liable as it happened to me once, I did it and it fixed the problem. bend the contact pins ever so gently inwards (torwards the oposing pin) so that it creates a bit more tension. you might have caused a bit too much slack on it when removing the old bulb but bend it gently as you don't want to break the pin....?
     
  8. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    Thank you @Electrician24 what do I check for? Where you at do you come out for a charge, I just need this fixed.
     
    Last edited by a moderator: 26 Nov 2015
  9. Electrician24

    Electrician24

    Joined:
    12 Aug 2011
    Posts:
    521
    Likes Received:
    9
    Location:
    Goodwood Cpt
    Bend it slightly towards you And call-out from capetown ?
    Sorry bud wish I was closer
     
  10. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    @gMAN will check it now.... these Pins that bloody sensitive?
     
    Last edited by a moderator: 26 Nov 2015
    Electrician24 likes this.
  11. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    @Electrician24 ouch CPT ok will check the pins .... eish
     
    Last edited by a moderator: 26 Nov 2015
  12. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    They can be, it is double ended fitting I'm assuming?
     
  13. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    @gMAN yes sir double pin i.e. one on each side....
     
    Last edited by a moderator: 26 Nov 2015
  14. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    any luck?
     
  15. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    Checked Pins - Clean as a whistle ... Also checked to see if they making contact when the bulb is in - yes it is
    Can I bend them nope they little nipple type Pins tried to bend them no luck.

    SH1T!!
     
  16. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    the nipple bit is on a piece of metal flap, try bending that...?
     
  17. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
    @gMAN - the nipple bit is on a plastic bit hang five for a pic....
     
    Last edited by a moderator: 26 Nov 2015
  18. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    they may be maikng contact as the fans need very little power to juice up but the bulbs need proper comtact.....
     
  19. mytank

    mytank Thread Starter

    Joined:
    12 Mar 2011
    Posts:
    2,503
    Likes Received:
    59
    Location:
    Gauteng
  20. gMAN

    gMAN with the plan

    Joined:
    2 Feb 2010
    Posts:
    3,039
    Likes Received:
    35
    Location:
    Houghton Estate, Johazzardousburg
    that looks pretty solid, give it till the morning.....
     
  21. RiaanP

    RiaanP Moderator

    Joined:
    11 Aug 2008
    Posts:
    23,142
    Likes Received:
    1,228
    Location:
    Centurion
    Switch the power off. Then use a multimeter, and just confirm first that the wiring between ballast and globe sockets are OK.
    It should be as the unit does look new.
    @lIghty, do you know what is the voltage delivered to the globe? If you know that you can switch the light unit on and see if the correct voltage is delivered. I know its very high on startup, thenit comes down. Not sure about the reading.
     
    Last edited by a moderator: 26 Nov 2015
Recent Posts

Loading...
Similar Threads - doesnt turn Forum Date
rinsing your food doesnt really reduce phosphates being put into tank General Discussions and Advice 31 Mar 2012
Dory doesnt like Nori Marine Fish Discussions 6 May 2009
Live feed doesnt update Forum Suggestions and Feedback 31 Dec 2008
External Return Pump Pumps and Waterflow 11 Nov 2016
[wtd] Return outlet nozzle Wanted 6 Nov 2016
[wtd] DC return pump Wanted 29 Oct 2016
Returning New Members 12 Sep 2016