Leather coral problem?

Joined
13 Nov 2007
Posts
327
Reaction score
1
Hi all,

I bought a leather pin cushion coral about a week ago, and it seemed normal, up to two days ago [well, today is the 3rd day]. It doesn't extend it's little arms any more - there's enough light in my tank [as my star polyps and xenias are fine]. There's no membrane or anything on the coral.

Attached a pic:

4184823fb616e5ef.jpg


Can anybody give any advise?!
Thanx!
Tinus :)
 
Joined
13 Feb 2008
Posts
1,434
Reaction score
74
Location
Cape Town
Give us your water parimeters please, can help from there...
 
Joined
13 Nov 2007
Posts
327
Reaction score
1
K, I've moved it - so now the waiting continues. Off to town in a short while, but will post again later with results (if any). Will take water parameters again as well, and post if no result. Thanx :) T
 

Bayls

Not often called Junior!
Joined
11 Dec 2007
Posts
107
Reaction score
1
Location
Johannesburg
Mine sometimes closes for a day or so, then its back bigger than ever the next day. Guess they also have their off days sometimes.
 
Joined
13 Nov 2007
Posts
327
Reaction score
1
Hey all! Well, this morning it was open! :) It seems like it shed some kind of skin or something, but everything is now 100% ---- is this the normal trend for this type of coral?

Thanx again for the help all :)
Tinus :D
 
Joined
28 Dec 2007
Posts
12,781
Reaction score
31
Location
JHB
Totally normal, every 2-3 weeks my leathers shed and withdraw their polyps. This is growth.
 
Joined
13 Nov 2007
Posts
327
Reaction score
1
well a bit of an update. Seems like it's a case of 1 or 2 days open, 2 to 3 days closed again... and this has been going on for quite a lot of time now - and every time there's like a thin layer of something being shed... is this normal? :)
 
Joined
28 Dec 2007
Posts
12,781
Reaction score
31
Location
JHB
well a bit of an update. Seems like it's a case of 1 or 2 days open, 2 to 3 days closed again... and this has been going on for quite a lot of time now - and every time there's like a thin layer of something being shed... is this normal? :)
Concerned about the every couple of days, are you sure there is not some sort of additive (Ca etc.) that is irritating the pin cushion ?
 
Joined
13 Nov 2007
Posts
327
Reaction score
1
I have no idea. Can't get a descent hardness test, cause the SERA test is !@#$. I've moved it today to the substrate - figuring it might be too much light... but will keep you updated.
 
Joined
5 Oct 2007
Posts
1,607
Reaction score
14
Location
Cape Town
Put it in strong flow, might not open for a couple of days but will adjust. Try not to move and touch it to often.
 

Top