King Pump problems

Discussion in 'Pumps and Waterflow' started by smartegoutte, 7 Jun 2010.

  1. smartegoutte

    smartegoutte

    Joined:
    6 May 2009
    Posts:
    70
    Likes Received:
    0
    Location:
    durban
    I use a King 5 and King 6 as recirculate pumps. I have a reoccurring problem and would like to know if others have experienced the same?

    The metal film surrounding the rotor starts to rust and lift off the rotor.

    I bought the pumps from Northlands in Durban and they have replaced the rotors free of charge in both instances. My concern is that it will happen again. I'm also concerned what effect it has on the tank. Does this encourage green hair algae?
     
  2. Guest




  3. deadmeat2016

    deadmeat2016 Wouter

    Joined:
    19 Jul 2009
    Posts:
    1,506
    Likes Received:
    22
    Location:
    Gordons bay
    Crap man, i use a king pump aswell and now u got me worried as i have to leave my tank for 3 weeks when i go to egypt :(
     
  4. OP
    smartegoutte

    smartegoutte

    Joined:
    6 May 2009
    Posts:
    70
    Likes Received:
    0
    Location:
    durban
    deadmeat apparently the older pumps had the normal solid rotor but the new ones are coated with a thin shiny metal strip.
     

Recent Posts

Loading...
Similar Threads - King Pump problems Forum Date
[wtd] Broken/non working DC5000 or DC6000 pump or impellor Wanted 23 May 2017
Zetlight King Kong WIFI Pump-11 Return Pump Jungle Aquatics 19 Feb 2017
Urgent help needed Ecotech Vectra L1 Retun pump stopped working Urgent Help Needed 15 Feb 2017
[wtd] Looking for Red Sea 250 Skimmer or Pump Wanted 15 Sep 2016
Thinking about buying NEW Jebao (Jecod) DCT AC/DC Pumps (2015 model) with 10 Spe... JungleAquatics.NET BLOG 18 Jun 2015
Thinking about buying Battery Operated Air Pumps? Read our latest review of the... JungleAquatics.NET BLOG 13 May 2015
Thinking about buying NEW Jebao (Jecod) DCT AC/DC Pumps (2015 model) with 10 Spe... JungleAquatics.NET BLOG 24 Mar 2015