Ice Machine

Discussion in 'The Sump' started by tinusb, 10 May 2009.

  1. tinusb

    tinusb

    Joined:
    13 Nov 2007
    Posts:
    327
    Likes Received:
    1
    Hi all

    Does anybody have a 'Ice Factory' as sold by EasyIce.co.za? I've got a problem with my machine, whereby it keeps on freezing the water, without getting rid of the ice cubes - you end up with the base of an ice cube being 1cm thick, thus not being able to break off, etc. etc. etc.

    OR is there anybody with vast knowledge on refrigeration, etc?

    Thanx!
    Tinus
     
  2. AdS Guest




    to hide all adverts.
  3. seank

    seank

    Joined:
    24 May 2007
    Posts:
    11,984
    Likes Received:
    119
    Location:
    North of Durban and South of Mozambique
    Thinus, check your "heat" thermoatsat. It is supposed to go thru the "cycle"where , after the ice is frozen, the pipes becomes hot, "realeasing" the cubes, if it works the same as the ice machines I know of
     
  4. Tony

    Tony

    Joined:
    23 Aug 2008
    Posts:
    4,093
    Likes Received:
    68
    Location:
    Honeydew, Johannesburg
    Some ice machines work on a tiny electrical charge to release the ice cubes or like sean said. Why not send it in for a service. I wortk in restaurants and we work with those giant industrial one but I'm sure it's the same principle
     
  5. tinusb

    tinusb Thread Starter

    Joined:
    13 Nov 2007
    Posts:
    327
    Likes Received:
    1
    Thanx guys! It's either the thermostat that's defective [ie. the temperature sensor] or the electronics board. I've contacted easyice.co.za - guy by the name of 'Richard', but after sales service is EXTREMELY poor. Tony, I'm in Windhoek - ice machine bought in Durban -- just the transport to Durbs and back would be the price of a new one almost I guess. Is there any way I can see or find out the rating of the temperature sensor, in order to be able to just replace it? Last option would be the board, I think... Richard told me it's the gas solenoid - but if you bridge the connection on the PC Board, the solenoid triggers without a problem. Weird thing is, the ice machine stood off for about a month, and after we turned it on, it made about 20kg of ice, normal without a problem, then it started it's sh!t again! :(

    Any ideas?
    T
     
Recent Posts

Loading...
Similar Threads - Machine Forum Date
MARINE RO Machines on Special... Aquaria 25 Feb 2015
[wtd] Algae Eating Machine wanted Wanted 9 Sep 2014
The tmc machine. Idol Marine 17 May 2014
You have to see this "The Aquaria Marine Platinum Pro RO Machine" .. Aquaria 5 May 2014
Urgent help needed RO machine broke Urgent Help Needed 15 Jan 2014
CNC Router/Machine Technology 6 Aug 2012
Welding Machine The Sump 4 May 2012