Help Needed - Red Sea Max Reef Mature Pro Kit

Joined
8 Jul 2017
Posts
51
Reaction score
15
Hi All

My tank is on day 4 of cycling and I am using the RS Reef Mature Kit, as well as the RS Marine Care Test Kit. I have been following the instruction and yesterday (Day 3) my parameters were as follows:
Temp 26.2'C
Salinity 1.025
PH 8.2
Kh 8.5
Ammonia around 0.6-0.8
Nitrite 0.1
Nitrate 10

Here is my query: I decided to use two thirds 'man-made', eco-friendly dry base rock, and one third Caribsea dry base rock instead of wet live rock. This was also recommended to me by my LFS and is popular with their clients. They also use same in their display tanks. I also used 20kg of Red Sea live sand (pink) in the display in lieu of not using wet live rock.

The parameters for where I am in the cycle do not seem too far off from what is stated in the kit, but I have yet to see any sign of algae in the tank (which according to the kit should be starting today or tomorrow). I am not sure then whether I should be adding the CUC next week Monday (as per Day 10 instructions) if there has not been a lot of algae growth by then. I assume that the lack of live rock and the use of dry rock has slowed the cycle as per the kit.
I would really appreciate your input on this.

Thanks, Lando.
 
Joined
8 Jul 2017
Posts
51
Reaction score
15
Hi Lando,

How many hours do you run your lighting for? What lighting are you using?
Hi there.

I am running my lights for 10hours as per the RS Reef Mature instructions. I have the standard t5 lighting included with the RSM C-250: REEF-SPEC® BlueWhite 3 x 39W REEF-SPEC® Actinic 2 x 39W REEF-SPEC ® Pink 1 x 39W.

I have read on a few other forums that it could possibly be due to me not using 'wet' live rock with initial setup.
 
Joined
8 Jul 2017
Posts
51
Reaction score
15
Are you in JHB? If so pop past the store and I will give you a few pieces live rubble rock to place in the tank to seed it.
Thanks so much for the offer - unfortunately I live on a game reserve almost 3hrs from Jhb and my work limits the amount of times I can visit. I was planning on making a trip next week so as to stock up on my cuc... And hence the concern over the algae, diatoms, etc. I am also not sure how putting them in later and not following the RS kit instructions will affect the cycle.
 
Joined
8 Jul 2017
Posts
51
Reaction score
15
Update on parameters for Day 5 (testing not required per RS kit for today, but taken anyway):
Temp 26.3'C
Salinity 1.025
PH 8.2
Ammonia 0
Nitrite 0
Nitrate 20

Glad to see ammonia and nitrite at zero.
 
Joined
8 Jul 2017
Posts
51
Reaction score
15
A rep from Red Sea has answered my query and he has confirmed that my cycle is on track as per the Red Sea Reef Mature regime... The algae bloom is not a 'requirement' per se, and is merely reduced due to the use of dry rock. The Red Sea NoPoX that I dose with in any event reduces the amount of algae and diatom bloom. I will be adding the CUC next week as per the regime as my parameters are currently in check.
 
Joined
17 Mar 2015
Posts
48
Reaction score
10
Location
centurion
Hi @Lando i saw the same thing with my tank cycled with dry rock and had 0 algae for the first month and a half, then i added a piece of live rock to the tank to introduce coraline and pods to the tank, it was like a bomb went off in my tank after that had algae everywhere including cyano. Iv only now been able to reduce all the algae to almost nothing after about 4 months. I personally wouldn't add live rock to my system or a new system ever again.
 

Similar threads


Top