Help extreme driving me Extremely Mad!

Discussion in 'Protein Skimmers, Mechanical Filtration' started by ziyaadb, 14 Oct 2009.

  1. ziyaadb

    ziyaadb

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    Help extreme skimmer not working properly

    So i went out and managed to get an extreme 200 external. Thing is that pump is driving me mad. everytime i connect the venturi for it to create the bubbles it starts vibrating and making a crazly loud vibrating sound. I got the original pump exchanged for a different one and this 1 is doing the exact same thing. Its so bad that i had it running outside and it could be heard inside the house. These are brand new pumps, striped, cleaned and put back in and its doing the same thing. When its just pumping water its fine as soon as the venturi is connected it goes mad. Anyone know whats the issue?
     
    Last edited: 14 Oct 2009
  2. AdS Guest




    to hide all adverts.
  3. scubaninja

    scubaninja

    Joined:
    20 Jul 2008
    Posts:
    6,739
    Likes Received:
    21
    Location:
    Durban
    Sounds like the pump may be cavitating. as in it has a huge air bubble on the wheel. if you let it pump just water for a while it may blow out the bubble or maybe you could tilt the skimmer/pump to get it to go out. this may stop it. you could also try restricting the air hose to see if its a possible fix
     
  4. ziyaadb

    ziyaadb Thread Starter

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    in a bucket with water its doing this disconnected from the skimmer, its just worse in the skimmer
     
  5. keyaam

    keyaam

    Joined:
    28 Jul 2008
    Posts:
    2,502
    Likes Received:
    16
    Location:
    Cape Town
    I had the same problem with a pump a few weeks back. Switch it on and off till you hear the noise is gone. What kind of pump is it?
     
  6. ziyaadb

    ziyaadb Thread Starter

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    its the PSK-2500 Sicce pump
     
  7. Falcon

    Falcon

    Joined:
    26 Feb 2008
    Posts:
    2,869
    Likes Received:
    31
    Location:
    VEREENIGING
    my return pump started doing this for the last few months sometimes it remains loud for up to a day but then it comes right.
    it hadnt done it during the first few years so im assuming its age.

    you got this issue with new pumps then somethings not right....maybe too much air being sucked?try throttling the air intake some how or check the impellers properly
     
  8. keyaam

    keyaam

    Joined:
    28 Jul 2008
    Posts:
    2,502
    Likes Received:
    16
    Location:
    Cape Town
  9. ziyaadb

    ziyaadb Thread Starter

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    cool thanks gents
     
  10. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    Yup @keyaam the problem is that the needle impellers have so much drag that they do not start properly. The most common cause is salt or dirt buildup on the venture not allowing enough air intake. The impeller is designed to caveatate, that is how the air is broken down to the white fine bubbles we all want. By blowing and sucking in a pant like manner on the air intake tube temporarily fixes most times however the fix is temporary. One really need to clean the venturi and ensure that no muck is restricting the venturi.
     
  11. ziyaadb

    ziyaadb Thread Starter

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    This is a brand new Venturi in a skimmer that has NEVER been used.
     
  12. Tony

    Tony

    Joined:
    23 Aug 2008
    Posts:
    4,093
    Likes Received:
    68
    Location:
    Honeydew, Johannesburg
    Z, hows the skimmer doing today?
     
  13. ziyaadb

    ziyaadb Thread Starter

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    Guys i took it back to the shop i bought it from and replaced it with a Orca 135. I am really disappointed but i received EXCELLENT service I really think that these pumps are better suited in internal skimmers and not recirc as i have never heard of problems with the internal ones and in the states only the internal ones are avail. anyways thats for the help
     
  14. lIghty

    lIghty

    Joined:
    3 Nov 2007
    Posts:
    5,053
    Likes Received:
    52
    Location:
    Westville, Durban
    Block the air pipe untill it pumps clean water then open the air line. this is a problem because of the way the pump is mounted imo.
     
  15. ziyaadb

    ziyaadb Thread Starter

    Joined:
    18 Jul 2007
    Posts:
    5,566
    Likes Received:
    48
    Location:
    JHB-Lenzz
    Thanks lighty. Done that a few times. The issue was the pump was pulling in too much air.
     
Recent Posts

Loading...
Similar Threads - Help extreme driving Forum Date
Extremely High Calcium Problem Please Help Water Parameters and Additives 13 Feb 2014
Overflow fitting help please Pumps and Waterflow 30 Nov 2016
coral help for covering a large surface area General Discussions and Advice 29 Nov 2016
Please help ORI with the KZN bait collection survey Diving, Collecting and Environmental Discussions 11 Nov 2016
Urgent help needed Please help/ fish looks like its dying Urgent Help Needed 7 Nov 2016
Help to ID live rock growth ID Needed 5 Nov 2016
Drilling ceiling help needed Anything DIY Related 22 Oct 2016