GHL Conductivity probe

Discussion in 'General Discussions and Advice' started by Marius Geyser, 19 Jan 2015.

  1. Marius Geyser

    Marius Geyser

    Joined:
    22 Jun 2013
    Posts:
    54
    Likes Received:
    0
    Location:
    Centurion
    Hi All
    I have recently bought a conductivity probe for a Profilux 3
    I am having trouble calibrating the probe.
    As it gives me a reading of 1.0209 witch is impossible.
    Is there other settings perhaps that I am not aware off.
     
  2. AdS Guest




    to hide all adverts.
  3. Marius Geyser

    Marius Geyser Thread Starter

    Joined:
    22 Jun 2013
    Posts:
    54
    Likes Received:
    0
    Location:
    Centurion
    I redid the calibration. Reading now on 1.0210
    rechecked the probe in the calibration fluid after calibration reading seems ok 51 ms.
    Is it possible that my salinity is really that low.
    I also rechecked water with refractometer . Got a reading of 1.025 on refractometer. The vertex refractometer that i am using is not temperature compensated. Could the refractometer be so mutch out.

    Dont know what reading to trust. Any Ideas.
     
  4. RiaanP

    RiaanP Moderator

    Joined:
    11 Aug 2008
    Posts:
    23,164
    Likes Received:
    1,232
    Location:
    Centurion
    Rather take your refracto first to your LFS and compare to their reading. Even with temperature compensation or without, the readings cannot be that far apart.

    If refracto is right, then redo the calibration on the probe. At least then you know that one of the two units got its reading correct and fixed.
     
  5. dallasg

    dallasg Moderator MASA Contributor

    Joined:
    14 Dec 2008
    Posts:
    16,771
    Likes Received:
    582
    Location:
    Sandton
    or test using a hydrometer, the large ones from tropic marin

    yes its a possibility your salinity is that out
     
  6. Marius Geyser

    Marius Geyser Thread Starter

    Joined:
    22 Jun 2013
    Posts:
    54
    Likes Received:
    0
    Location:
    Centurion
    Thanks

    Will do. Two weeks ago was at the LFS and asked them to test my salinity. They have tested with a Hanna. That is why I took the probe back to the LFS thinking it is faulty. They have send it back to their principals. Have reported back that the probe was 100%.

    Did some more tests. Probe in RO Water 0.9978 Probe in Tank or Sump 1.0208

    Probe in 50ms calibration fluid 51ms so it is very close.

    Leaving me to the conclusion that my refractometer without temperature correction is possibly that far out. Or probe is not doing the calculation correctly.(Witch I dough) I did check the refractometer with ro as well , was very close to zero.

    I did have a large hydrometer a couple of years back. Dont want to buy one just for this test.

    But in the same breath I would really like to get to the bottom of this.
     
  7. NO3

    NO3

    Joined:
    26 Jul 2013
    Posts:
    592
    Likes Received:
    30
    Location:
    Durban,Hillcrest
    Get a floating hydrometer the glass one that floats(a decent brand) warm water to 25 deg and test, those things never loose calibration!
     
  8. Marius Geyser

    Marius Geyser Thread Starter

    Joined:
    22 Jun 2013
    Posts:
    54
    Likes Received:
    0
    Location:
    Centurion
    Thanks found the problem refractometer out again. Went to LFS and tested a sample of my water with a hydrometer. 1.0218 and electronically with a Hanna 1.022 re calibrated refractrometer.

    Note to self Self make sure you refractrometer is calibrated before you post here.

    The GHL probe seems ok reading at 1.0217
     
Recent Posts

Loading...
Similar Threads - Conductivity probe Forum Date
Profilux Conductivity Probe and PH calibration Fluid Wanted 8 May 2012
conductivity controller General Discussions and Advice 22 Mar 2009
[wtd] STC 1000 temp probe Wanted 16 Oct 2016
[wtd] Ph probe Wanted 11 Sep 2016
[wtd] Ph probe and controller Wanted 2 Jul 2016
[wtd] STC1000 Temp probe Wanted 12 Jan 2016
Probe Holders Anything DIY Related 17 Dec 2015