Faulty aquamedic return pump

Discussion in 'Pumps and Waterflow' started by EFJ, 6 Dec 2012.

  1. EFJ

    EFJ MASA Contributor

    Joined:
    13 Sep 2011
    Posts:
    1,537
    Likes Received:
    278
    Location:
    Dwaalboom 60km's from Thabazimbi
    Hi MASA. My tank is still cycling so no serious issues with live stock, here is my problem my aquamedic ocean runner 3500 is not pumping the volume it should. Actually quite a bit weaker than it was. This happened since my washing machine's drain overflowed and ran on a power plug and tripped my power (my PVR also decided to go on vacation). My question is how do I check if my pump has picked up any damage? I checked and cleaned the impeller and parts and couldn't find anything faulty. As far as I know if it is damaged internally it shouldn't work or it should at least be noisy.
     
  2. AdS Guest




    to hide all adverts.
  3. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    Check the impeller rotation direction. It may be turning the wrong way.
     
  4. EFJ

    EFJ Thread Starter MASA Contributor

    Joined:
    13 Sep 2011
    Posts:
    1,537
    Likes Received:
    278
    Location:
    Dwaalboom 60km's from Thabazimbi
    How do I know which is the right direction?
     
  5. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    Long time since i opened a ocean runner. let me check for you.
     
  6. EFJ

    EFJ Thread Starter MASA Contributor

    Joined:
    13 Sep 2011
    Posts:
    1,537
    Likes Received:
    278
    Location:
    Dwaalboom 60km's from Thabazimbi
    If its turning the wrong direction how would I get it to run in the correct direction?
     
  7. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    I need to check before i can help you. some pumps have a flapper that redirects the flow. Others have a brake that changes the impeller rotation direction. I can't remember what method the AM pump uses.

    Try and switch the pump on and off quickly a few times. You will see a difference in the pump performance if this is the case.
     
  8. EFJ

    EFJ Thread Starter MASA Contributor

    Joined:
    13 Sep 2011
    Posts:
    1,537
    Likes Received:
    278
    Location:
    Dwaalboom 60km's from Thabazimbi
    OK will wait for your reply. Will also do that on/off check.
     
  9. EFJ

    EFJ Thread Starter MASA Contributor

    Joined:
    13 Sep 2011
    Posts:
    1,537
    Likes Received:
    278
    Location:
    Dwaalboom 60km's from Thabazimbi
    Yeah!!!! Got my pump working. All that was wrong was that the top part of the impeller (the one with the blades) is suppose to move freely and it wasn't. Just a little bit of cleaning with sand paper and wola it works.:thumbup:
     
Recent Posts

Loading...
Similar Threads - Faulty aquamedic return Forum Date
Faulty RSM 250 cooling fans RSM Red Sea Max tanks 27 Jan 2014
Faulty DC-10000 whats the returns procedure from Cpt to jhb? Jungle Aquatics 10 Sep 2013
Faulty Salifert Nitrite Tests Anyone? Test Kits, Controllers, Reactors and Dosers 15 Dec 2012
Puritech RO unit maybe faulty? Test Kits, Controllers, Reactors and Dosers 13 Sep 2012
Faulty T5 Ballast Lighting 9 Jul 2011
Faulty Giesmann Lighting 4 May 2011
Faulty Hydrometer or not? Beginner Discussions 12 Feb 2011