DD Ro unit keeps dripping

Discussion in 'Test Kits, Controllers, Reactors and Dosers' started by Momo, 6 Jul 2013.

  1. Momo

    Momo

    Joined:
    9 Mar 2011
    Posts:
    216
    Likes Received:
    6
    Location:
    Greenstone - JHB
    Hi,

    Got a dd ro unit which lately keeps dripping. It's connected to a copper pipe and guessing that is where it doesn't close properly. Anyone have an idea how to fix?
     
  2. AdS Guest




    to hide all adverts.
  3. Nemeziz_za

    Nemeziz_za

    Joined:
    25 Sep 2012
    Posts:
    1,584
    Likes Received:
    39
    Location:
    Durbanville, (Cpt)
    Got a pic?
     
  4. Momo

    Momo Thread Starter

    Joined:
    9 Mar 2011
    Posts:
    216
    Likes Received:
    6
    Location:
    Greenstone - JHB
    of what the drip? lol it drips out the out the clean water pipe. so basically as if the unit was not turned off. it's not dripping at any connections. if i put the setting to flush the unit i get quiet a strong flow coming out even though the tap is closed.

    don't have pic of the actual unit but it's the below items.
    Pipe connector

    [​IMG]
    the unit

    [​IMG]
     
  5. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    Momo is the drip coming from the brass tap bit or the aluminum clamp or the fitting where the plastic pipe fits in?
     
  6. Momo

    Momo Thread Starter

    Joined:
    9 Mar 2011
    Posts:
    216
    Likes Received:
    6
    Location:
    Greenstone - JHB
    No there is no drip from any of the fittings. there is just a constant drip from the clean water pipe (filled a 25l bucket in 2 days). or if in flush setting from the waste pipe. it seems almost like the tap doesn't close properly.
     
  7. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    OK so the brass tap on the fitting does not shut off the water supply to the RO unit.

    Never had that issue personally. Will enquire for you and get a fix.
     
    Last edited: 6 Jul 2013
  8. Momo

    Momo Thread Starter

    Joined:
    9 Mar 2011
    Posts:
    216
    Likes Received:
    6
    Location:
    Greenstone - JHB
    Last edited by a moderator: 26 Nov 2015
  9. Momo

    Momo Thread Starter

    Joined:
    9 Mar 2011
    Posts:
    216
    Likes Received:
    6
    Location:
    Greenstone - JHB
    Last edited by a moderator: 26 Nov 2015
  10. Nemos Janitor

    Nemos Janitor

    Joined:
    7 Feb 2009
    Posts:
    8,384
    Likes Received:
    286
    Location:
    Joe's Mountain
    Pm me your details so that I can contact you in the morning.
     
Recent Posts

Loading...
Similar Threads - unit keeps dripping Forum Date
[wtd] RO unit wanted Wanted 26 Nov 2016
[wtd] Broken or unused led unit Wanted 21 Nov 2016
[wtd] R.O. Unit Wanted 29 Oct 2016
[wtd] ATI 6 or 8 bulb 39w unit Wanted 17 Oct 2016
RO unit waste water used for freshwater aquarium? General Discussions and Advice 7 Oct 2016
Decent 24w 2 bulb t5 unit? Lighting 5 Oct 2016
[wtd] Complete calcium reactor unit will all bells and whistles Wanted 22 Sep 2016