Aqua H2O pumps

Discussion in 'Pumps and Waterflow' started by cybervic, 13 Jun 2008.

  1. cybervic

    cybervic

    Joined:
    4 Jun 2007
    Posts:
    453
    Likes Received:
    6
    Location:
    Kimberley
    What are your views on Aqua H2O pumps? are they worth using in a marine setup?
     
  2. AdS Guest




    to hide all adverts.
  3. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    tried it out some time back but the shaft packed up in about a month :(
    ive been using lifetech,very pleased with it
     
  4. brentnorm

    brentnorm

    Joined:
    6 Dec 2007
    Posts:
    2,198
    Likes Received:
    11
    Location:
    Cape Town
    I have a 3500 running in my sump for 7 months now and no problems so for. I just hope I am not putting a curse on myself now.
     
  5. Mekaeel

    Mekaeel Moderator MASA Contributor

    Joined:
    8 May 2007
    Posts:
    24,229
    Likes Received:
    127
    Location:
    Point Waterfront Durban
    dont take my word for it.it could have been just a faulty pump
     
  6. HenkHugo

    HenkHugo

    Joined:
    10 May 2007
    Posts:
    3,629
    Likes Received:
    29
    Location:
    Cape Town
    i will stay far far far far away from any aquah2o products other than their tanks.... rather gor for LifeTech/boyu/hailia
     
  7. viper357

    viper357 Admin MASA Contributor

    Joined:
    4 May 2007
    Posts:
    27,980
    Likes Received:
    776
    I have been running 4 of those pumps, 2 for return pumps, 1 for chiller and 1 for UV, never had a days trouble with any of them.
     
Recent Posts

Loading...