Algae issues

Discussion in 'Beginner Discussions' started by Boyu TL 550, 10 Jun 2011.

  1. Boyu TL 550

    Boyu TL 550

    Joined:
    23 Apr 2011
    Posts:
    66
    Likes Received:
    0
    Location:
    cape town
    hi guys tank been running since feb. algae been growing on the back of my tank and the last 3-4 weeks starting on my live rock! is this ok or harmful? doesnt look that nice on live rock [​IMG][​IMG]
     
  2. AdS Guest




    to hide all adverts.
  3. bothal08

    bothal08

    Joined:
    9 Jun 2011
    Posts:
    375
    Likes Received:
    1
    Location:
    slummies
    ive got the same problem...if u dnt mind im tagging along
     
  4. mupwi

    mupwi

    Joined:
    18 Aug 2010
    Posts:
    466
    Likes Received:
    2
    Location:
    Durban South Africa
    taging
     
  5. Alan

    Alan Admin MASA Contributor

    Joined:
    4 May 2007
    Posts:
    5,974
    Likes Received:
    119
    Location:
    KZN
    Not harmful at all, and in a new system its still part of the cycle. From the pics it doesn't look too bad, i have seen far worse.
     
  6. Boyu TL 550

    Boyu TL 550 Thread Starter

    Joined:
    23 Apr 2011
    Posts:
    66
    Likes Received:
    0
    Location:
    cape town
    will it eventually go away?
     
  7. Tremayn

    Tremayn

    Joined:
    21 Mar 2010
    Posts:
    5,226
    Likes Received:
    69
    Location:
    Lenasia
    yes as the tank matures
     
  8. bothal08

    bothal08

    Joined:
    9 Jun 2011
    Posts:
    375
    Likes Received:
    1
    Location:
    slummies
    thats good to hear
     
  9. Colin

    Colin

    Joined:
    11 Jan 2011
    Posts:
    53
    Likes Received:
    0
    Location:
    Vanderbijlpark
    just keep ur N02 and NO3 very low....
     
  10. slless9

    slless9

    Joined:
    5 Apr 2011
    Posts:
    56
    Likes Received:
    0
    Location:
    Cape Town
    can i ask a dumb question, some poeple have said just leave the algae that goes away naturally, others saying clean it.....but i tried the latter and it just comes back after while....dam confused now....
     
  11. Xereo

    Xereo

    Joined:
    10 Feb 2011
    Posts:
    1,154
    Likes Received:
    0
    Location:
    Cape Town
    You can Clean it. But also if you just leave it, it goes away in time :)
    As soon as there is no more food for it in the new tank it will die off :)
     
  12. archiecrain

    archiecrain

    Joined:
    23 Jun 2010
    Posts:
    1,391
    Likes Received:
    59
    Location:
    Fourways
    By cleaning it off you still not removing the cause of it.....once your nutrient levels are too low for it to survive it will disapear.
     
  13. Evo R

    Evo R

    Joined:
    8 Dec 2009
    Posts:
    1,740
    Likes Received:
    33
    Location:
    Mosselbay
    Po4 is also a big factor in GHA.What fitration do you have?
     
  14. Sammy

    Sammy

    Joined:
    19 Apr 2008
    Posts:
    1,191
    Likes Received:
    6
    Location:
    Tokai, Cape Town
    Sorry guys, I have some input but ONLY my experience with algae and TL-550, was a nightmare I tried EVERYTHING, 80% water changes on multiple occasions, bought RO and synthetic salt, PO4 No3/3, carbon, phos, purigen, all bad params zero the algae did not go away, I then had no choice to upgrade to a new tank and get a sump ???

    Would like to tag along and see what you guys do to sort it ?
     
Recent Posts

Loading...
Similar Threads - Algae issues Forum Date
Macro algae ID needed ID Needed 4 Jan 2017
Macro algae in display tank - Yes or No? General Discussions and Advice 7 Dec 2016
[wtd] Macro Algae Wanted 6 Dec 2016
Looking for a hog 1or hogx1 uplift algae scrubber General Discussions and Advice 5 Dec 2016
Black algae Nuisance Algae 1 Dec 2016
Algae ID needed Nuisance Algae 18 Nov 2016
Advice on algae growth Nuisance Algae 17 Nov 2016