Advice needed

Joined
23 Apr 2015
Posts
22
Reaction score
0
HI,

My rocks in my tank are getting like a brown algae on them, how do I get rid of this, also what causes this, the tank is now 8 months old?
 
Joined
25 Sep 2008
Posts
1,123
Reaction score
71
Location
Fourways
This could be one of many things ( dinoflagellates, diatoms or just plain brown algae).
Normally signifies that there are excess nutrients in the water column and on the rocks (e.g. debris from uneaten food etc.)

Please post a pic if you can and share your water parameters , filtration used and what livestock you currently have
 
Joined
23 Apr 2015
Posts
22
Reaction score
0
Thank you for the feedback, Im trying to upload a picture it keeps failing, Its a red sea tank 240 l external sump, I have about 6 fish in , nemo ,7 line ras , PJ cardinal , blue green chromes .
Is there any any I can get rid of it ? Will try to upload the picture again.
 
Joined
25 Sep 2008
Posts
1,123
Reaction score
71
Location
Fourways
Manually removing the brown algae is just treating the symptom. You need to find the cause of the algae outbreak , otherwise the algae is just going to return.
  • Check your Nitrates & Phosphates
  • Ensure that there is sufficient flow in the DT to keep debris suspended in the water column
  • Check your skimmer to ensure that you skim wet (i.e. more liquid and less dry foam)
  • Check your feeding regime (e.g. if you're feeding twice a day, perhaps cut down to once per day or once every other day)
 

Similar threads


Top